Mixamo Import FBX Black Facial Features FIXED

Mixamo FBX in Blender BEGINNER-EASY FIX: Black Area Around Facial Features = GONE!
I haven’t found this solved anywhere, so I’m posting the answer. Most replies say: prolly the UV, add a light. Not helpful–especially to us newbies to 3D. It’s just that their opacity is set to 100% without alpha (by default). So to honor the png transparency, you change that setting.

2 min video on YouTube or written steps below: YouTube videos for Blender or Photoshop fixes

Note: I am not a developer, I’m a teacher trying to help students get going in 3d…I’m not well versed with lingo and protocols. I offer my solution in laymen’s terms. Please, experts, feel free to expand or explain or correct me on why this works. I’d LOVE an expert to say, “if you did ___ during import, these would already have alpha enabled” or something even simpler than adding alpha to each Mat property!! I just want newbies to get to start somewhere, especially if they don’t have the means to take official courses etc just yet.

Problem:
For some reason the fbx Mixamo models are imported with 100% opaque faces (except the body was fine in my case…it was just the facial animation map pieces). This isn’t complicated. No amount of “lighting” or “UV” helps if they’re not using the alpha supplied in the png!
Solution:

  1. Select Material that’s black (layers panel yellow triangles -> red spheres icons)
  2. go to Material Properties (below layers->click sphere icon)
  3. scroll to settings, change blend mode to alpha clip.
    The end :slight_smile:

Very Detailed Solution:

  1. In the 3D viewport, in Object Mode, in Orthographic (idk if this matters), click far right top icon to show colored model so you can see the black parts. Then, open the armature layers panel and the properties panel (if it doesn’t auto-show below layers).
  2. Expand armature layers (click white arrow for dropdown), and expand all the orange triangle layers (underneath the bones layers). Keep expanding orange triangle layers until you see the red sphere icon in each.
  3. Click/select/highlight the first red sphere icon for a body part that shows with black around it (or is black) in your view.
  4. Now underneath, (default Properties of that layer) click the red sphere icon (section is second to bottom) and scroll down past Preview, Surface, & Volume to SETTINGS. (click to expand settings)
  5. Note Blend Mode & Shadow Mode are set to Opaque. This means the png’s transparent background isn’t showing, just the black (as if it had been saved as jpg).
  6. Change Blend Mode to Alpha Clip or Alpha Hashed. Voila!

Repeat for all pieces that are showing as black

I am not an expert so idk which is better-hashed or clip- they both seem to do the same thing. I had some issues later when I chose “Alpha Blend” and I have no clue why, so I stuck with clip and all seemed to do what I wanted :smile: And FYI I didn’t see a difference when I changed “shadow mode” to alpha, but seems like should probably match whatever you pick for Blend Mode? Maybe an expert will reply and tell us.

I know this is not a “developer level” answer, my intent is to help those just starting and kids (without making them go take a 6 week course on “So you want to learn 3D animation”). They’re 12. They are actually trying, so let’s help them!! And…maybe just give those starting to explore a break without attacking?