Mixing NLA and F-Curves does not work?

Hi All,

I am playing around with the Pantin character rig.

I have animated the hips to move up and down along the Z-Axis. Then I converted that to a NLA strip by clicking the snowflake. I extended the strip by increasing the repeat. Great, it all works and the character stands there moving up and down.

So I want the character to move forward along the Y-Axis. So I set a single channel keyframe for Y axis to 0.0 at frame #1 and them move ahead to frame #20 and set another keyframe with the Y-Axis set to -1. I set the channel interpolation to liner extrapolate to create an infinite slope along the Y-Axis.

Now the GUI quite clearly shows the infinite slope for my values in the f-curve editor, but the numeric value in the 3D viewport never change. Can anyone explain what is going on with this BLEND file?

I expected the RIG to move forward and bounce up and down as it did so. It seems like NLA strips cancel fcurves? But even if I convert the f-curve to a NLA strip the values still do not work.:confused:

Attachments


25_RIG_Pantin_1a.blend (281 KB)

Looks like you’ve accidentally enabled “solo” mode on the NLA track (where just that NLA track gets activated).

Oh, I did not even notice that graphical decoration. You mean the tiny little dot to the left of the word “NlaTrack”?

When I turn it off, I do see some movement in my Y-location, but it is not infinite. Even though I have not activated the SnowFlake for the Y-Location, the NLA still treats it as if it were already converted to a NLA Track.

I guess I am asking is it possible to do this? Mix f-curve and NLA. As far as I can see, it is not. But once again I could be missing something.

Take my previous upload and un-solo it (I wonder why Blender makes NLA Tracks solo by default?) Shouldn’t the body continue to move forward along the Y-axis? The f-curve is an infinite slope.

If you have ever used professional audio apps they have a BIG area that lights up with the word “SOLO” or “MUTE” if you have tracks soloed or muted. This would be a nice feature to add to Blender as well.

Ah yeah, forgot about that part.

  • IIRC, this didn’t use to be a problem in the past, before I added some tweaks which were part of an unfinished bid to get layered-animation stuff working (i.e. treat active action as NLA strip when NLA tracks exist) meant that extrapolation like this is ignored. Anyways, it’s now on my todo list to tackle (perhaps in the next day or so)
  • Having seen a few problems come up related to confusion about solo, I’ll be looking at making some visual tweaks to make this a bit more obvious.

Cheers for bringing this up.