mixing sketch render set up with colored objects

I kinda got an issue here with my node set up. I have a three render layers set up.

  • a shadow pass
  • an edge pas
  • and a texture pass to put people cut outs in front of my objects.

I learned the set up from the sketch style render tutorial.
http://matthieu3d.free.fr/TutoVira1/tuten.html

btw this is a huge spiral freezer with a conveyor belt that spirals round a drum.
The issue that I have is that, I want to render only one object in color (the conveyor belt), but if I do it as an alpha over it then just covers everything thats behind it. It needs to blend in with the other objects.
Does anyone have experience with this set up or did something similair.
thnks in advance

Attachments



From your node setup it looks like you need to add a render layer for the conveyor belt, just like the one with the two guys.

Thanks for answering Mats,
but the things is I tried that already, i mixed it with an alpha over node, but then i get the object (conveyour belt) on top of the render not mixed in with the rest of the machine. I’m pretty sure this is possible but i’m not that good with compositing.

You need to mask the coloured objects. Put all the BW parts in, say, scene-layer 2 and the coloured object in scene-layer 3. In the render-layer panel you activate scene-layer 2 and Ctrl+click scene-layer 3 to use it as a mask. If you render that render-layer you should have only the coloured parts masked-off by the BW parts. Use alpha-over to add it to your final output.

thanks man!!
did not know about the ctr-click.

Now their seems to be another issue though, if the coloured part is behind the big transparent wall, it will not render in color. I also from the beginning could not get to render a transparent face with edges. I have a feeling it has to do with the z-buffer, but i do not exactly understand what the render options and passes do in the render layer settings.

…coloured part is behind the big transparent wall, it will not render in color…

Uh… I’m unable to reproduce this. Does it turn all black? Maybe you didn’t turn transparent shadows on (F5>Shaders).

…render a transparent face with edges…

Neither can I (the Edge button in the render-layer menu actually say “Only works for solid faces”). You could move a copy of your box to another Scene-layer and assign a new non-transparent material to it. If you in a separate render-layer enable edges only, you should get a transparent image with only the outline of the box. (Or set the new material to wire.) Best I can come up with.

I actually achieved what i wanted by doing the following:

  • Transparent box and coloured object in different layers

  • shadow layer: renders every layer but only passes the shadow on

  • Edges layer: renders only edges with transparent object activated and masked, color object turned off.

  • Color object layer: everything masked and only color objects on

  • people layer

The only thing that seems impossible to do is to render a semi transparent object with edges.

btw, thnks for all the help

Attachments