MMB and Shift

In Blender 2.49 I am be able to rotate the view port with MMB and quickly pan by pressing shift while holding MMB and then rotate again by releasing shift.

In Blender 2.5 Beta I can rotate with MMB but if I want to pan I need to release MMB hold shift and then MMB again. I can’t quickly toggle between rotate and pan by pressing and releasing shift.

Is there a way to get this Blender 2.49 functionality in 2.5 Beta?

Someone gave me this advice:
Go to user preferences - input - 3d view - 3d view (global)
(you must activate “edit” before you can change anything)
locate Rotate view (third entry down) Setting: Shift middle mouse
locate Move view (fourth entry down) Setting: Middle mouse
Scroll down the list till you find Translate

Change from Translate (Tweak, Select, Any) to Translate (Tweak, Action, Any)

cheers

chapel

Hey Chapel - thanks for replying.

However, your suggestion just changes panning to MMB and rotate to shift + MMB.

I like the default setting of rotating with MMB but what I would like to do is while I’m rotating to be able to press shift and it changes to move (all the while still holding the MMB) and then release shift to continue rotating. This makes it real easy to rotate and pan around an object without having to constantly pressing MMB.

Hello there !

After much frustration, and having seen a build that does exactly this, I studied its custom settings and managed to set them up again.

It’s all under 3D View (Global) at Input tab in the preferences.

I first added two new mappings at “Rotate View”, one for Shift and one for Ctrl, to switch to Move and Zoom respectively. (You add things by pressing “edit” and then expanding the nodes downwards.) I post a picture of how “Rotate View” became.

http://i31.tinypic.com/5cdmhk.jpg

Unfortunately it’s not so intuitive to add the shift and ctrl keystrokes. You will have to experiment in the boxes until you get them right. As a default keystroke, the letter A appears, so right click and set to default value. Then press on it and add the keystrokes.

Under “Move View” I added the shift keystroke so that it switches to rotate when released.

http://i30.tinypic.com/o0w2f9.jpg

Similarly in “Zoom View” I added the ctrl keystroke to switch to rotate again when released.

http://i27.tinypic.com/dlkxs5.jpg

I am pretty certain that this build i had tried had other additional settings, which I don’t remember now.

I hope I don’t cause any problems with this. After all it’s very easy to remove those extra nodes. The only hard part is to manage to have it add the keystroke. It’s very confusing and I had to experiment a lot.

Anyway, I had to share my experiment because it saved me from amazing frustration. My wrist hurts after only a few mouse button presses so this was top priority for me to solve too. I am very sad to see that many people don’t care about this issue at all. But of course the people who designed the interface know better. You can customize everything.

Cheers !

Hey Ubik - thanks for replying.

I tried your changes but got stuck at the point when adding the “switch to rotate” settings in move modal and zoom modal. I don’t have the choice of selecting “switch to rotate”. The only option I can select is “confirm”.

How do I enable “switch to rotate” as an option to select in the move modal and zoom model parts?

Thanks again for looking into this - I would never have figured it out!

Its working - installed a later build (r30928) and I was able to select “switch to rotate”.

More info

I found the following log entry for Blender 2.53 Revision: 30868 (from http://www.mail-archive.com/[email protected]/msg16478.html)

Log Message:

Added back modal keymap items for view manipulation mode switching in
zoom/pan, so they can be added in customisation. Not sure why these were
removed.

I was running Blender 2.53 r30581. I got the latest build from http://www.graphicall.org/builds/ and it fixed this issue.

Thanks again ubik for your help.