model flipping problem

hi, i have modeled a creature, it looked better when rendered in blender, however part of the model surface was hollowed in texture mode, i used ‘recaslculate inside and outside’ and ‘flip’ but no luck, the model surface just flipped alternately, question is how do i flip the model surface uniformly???

It depends on your model. If ‘recalculate’ does not get your normals to be correct then I think you have to either:

  1. look at your topology and see what is confusing Blender. "non-manifold’ faces make it hard for Blender to compute the correct normals.
    -OR-
  2. Manually select each face that you need to correct flip them on a case-by-case basis.

thanks, i used the 2nd method but its quite messy n slow. by the way, how to avoid this problem while modelling? so that i dont have to deal with the flip settings later?? about the topology , didi u mean the ‘retopo’ button at mesh editing mode? i clicked it but nothing happened…

There really isn’t any way to really avoid this problem all together as it will happen from time to time, but one rule of thumb is when doing extrusions, extrude away from the surface normal and faces will point outward. Also displaying the normals during construction will give you and idea of how things are moving along from the beginning so you can make corrections early.

Can you post your .blend or some wireframes of your model? It would probably be more helpful to point out issues with your current mesh than to tell how to avoid this while modeling in general. If you are looking for general advice then it would be to watch some modeling tutorials on youtube and cgcookie. They show common workflows that generally avoid situations like this or can be easily corrected with a simple “recalculate”.

about the topology , didi u mean the ‘retopo’ button at mesh editing mode? i clicked it but nothing happened…

Nope, I ment “topology” in the general sense of how your model is put together and how the vertices and edges are laid out to create faces. I’m not sure which “retopo” button you are talking about. Off the top of my head I only know about the grease pencil “retopo” button but I would not be surprised if there were some more hanging about.

ok, here u go. the model is fine in object mode with ‘set solid’, once u change it into set smooth, u begin to notice part of the model surface appear to be blacken due to uneven
flipped surface, or u can just change into texture mode… this is 2.49 version

Attachments

crab.blend (677 KB)

shading getting weird when in smooth mode is a good hint that there are several bad things with the model.

To get an idea in which locations the model needs to be repaired, in Edit Mode, while in vertice selection mode, unselect the whole model and click on Select -> Non Manifold.

There are duplicated vertices/faces and overlaps in several zone of your model, the non manifold will help you to see exactly where.

Perhaps retopo is the best way to get yourself out of this mess. Looking at the .blend, I think it would take longer to repair than it would to retopo. Also, it can be helpful to deselect “2 Sided” in the Object Data menu. Alternatively, while in edit mode in the 3D view properties under Mesh Display, you can enable face normals or vertex normals.