Model is symmetrical, but uv map is not.

I have just unwrapped a lion head using the angle based method. In the UV editor, I have the points along the y-axis pinned in a row, which causes the unwrapped mesh to look nice and symmetrical. However, the points differ very slightly in position on either side. At first glance, everything looks symmetrical, but mathematically speaking, the two sides are not. For my purposes, I would really, really like to have both sides perfectly symmetrical.

I have also tried the conformal unwrap method. This gives me better results mathematically speaking, but there are still a few UVs that are very minutely off.

Is there anything I can do to get my uv map perfectly mirrored about the y-axis?

Here’s an image to visually demonstrate what I’m doing:


Interesting i never noticed that problem before as i always thought both side were always symetrically the same (and it always looked like it), but i just tried on a head i modelled (with the mirror modifier, so both side are exactly the same when i apply the modifier, no topology difference) and obtain the same result as you.

And it does the same if i give a try in 2.49b

edit : used a cube subdivided a bit and applied the modifier, then unwrapped it, and did the mirroring test, and :
With this, it is closer to being exactly symetrical, but zooming in and you’ll notice the problem is still present.

The only method i found to have exactly both side of the UV symetrical is this :

  • Make your unwrap for the full model as usual.
  • once done, delete 1 side of your model entirely.
  • add a mirror modifier and apply it to recreate the side you just deleted.

Doing this will have both side having the same exact location on the UV map.

-Now in the 3D View, select only the side you just recreated.
-In the UV editor, snap the cursor to one of the middle point (as you did on your test), set the pivot to be the 2D cursor
-Select the whole unwrap (as you have only 1 side of the model selected in 3D view, the whole unwrap is in fact only the one corresponding to that side)
-click CTRL+M and press X to set it on the X Axis.

That’s it, you have your full UV now being completely symetrical.

I think this should be reported as a bug, and if possible fixed.
It´s a perfect example of the shortcomings of Blender.

You want to achieve something that seems completely logical and most likely works in other 3D tools like expected.
In Blender you’re coming to a full halt and think WTF.
Then you have to find out what´s wrong, often enough no one knows what’s wrong.
Then you have to find a workaround and lastly you have to apply a workaround and you waste time for something that just isn´t working right.

And if you start pointing out those flaws you’ll get flamed “but it is working, just different” :slight_smile:

I doubt anyone would say “this is not a bug it’s because Blender is different”, there’s simply no way the unwrapping is actually intended to work like this and fail at doing its job in symetry.
Definitively a bug, and considering how important unwrapping a model is in a workflow, both for hobbyist and for professional work, it’s not a small bug.

i’v also seen this non symetrical effect on other unwrap i did last week
and it was a pain in the neck to correct it and annoying!

hope someone at leat make a bug report on this
and see the answer if not a bug dev wll tell you

happy 2.6