Model sunk below on Z axis

Hey guys,

I am following along in the wikibook tutorial and I modeled a basic house with ground. I somehow have moved the house and the ground plane it rests on below the default work area along the Z axis. The house now looks like it has sunk below the default work area. How can I restore the house back to the default position on the Z axis?


In edit mode, select bottom vertices of your house, Shift+S -> Cursor to Selected. Then leave edit mode, and having house still selected, in the bottom menu select Object->Transform->Origin to 3D cursor. These two actions will place your house’s origin at its very bottom. After this, the location can be easiliy controlled in the Transform pane of properties box (N key): at the very top there are Location settings. Set Z to 0, and your house will be placed at grid floor.

If your house consists of several objects you can either perform similar operations on them, or just ‘parent’ them to house base (select all the objects, shift select house base, Ctrl+P->Object) before moving house base.

Thanks Stan!