Modeling macintosh-set smooth

I am creating this mac and made the cd drive cover flat with a bit of an edge, but when I go to say “set smooth” it puts this shadow like thing there, as if it were indented and not flat. how do i fix this?
pics- smooth on solid


Not sure exactly the problem without a screen shot, but try recalculating normals (ctrl+n). You may also want to try turning on ‘Autosmooth’.

I can’t see the images. Try embedding them onto the post.

I did recalc the normals, that didn’t help. and I though ‘autosmooth’ was the same as ‘set smooth’ next to the ‘set solid’ button. one of the screen shots is set solid so you can see that it is truly flat.

Set smooth is, as I understand it, an optical illusion based on normals direction and it attempts to visually “smooth” the transitions between adjacent faces - even if they go around sharp bends. Auto smooth is the same except that it allows for edges as defined in the Degr: parameter.

You can test the difference by trying each on the default cube and looking at a render. You can see in this test that while the cube remains perfectly sharp in outline, Set Smooth blurs the edges and attempts to make them appear as if there is no edge at all.

You can also Set Smooth in Edit mode and apply the effect to selected faces only - though this may not help in your current situation

In many cases, for photo-realistic-quality models, you’ll get better results by adding edge geometry and using Subsurf with Set Smooth. This also gives you realistically “rounded” edges.

Try auto-smooth first probably.

Im guessing subsurf has been aplied, if it has then bevel before hand and it should come out right.

thanks for your help, but auto smooth doesn’t help, it was subsurfed, but i converted it to a mesh and set smooth makes those shadows with extreme angles. so i just modeled it differently. thanks for your support, I hope they get that glitch fixed in the next release of blender.