Modelling a cup of water

I’m quite new to blender and I recently undertook the project of modeling a glass of water. I took two cylinders and subtracted the larger from the smaller one to create a cup. Another smaller cylinder placed within the larger one serves as my model for water.

I followed this tutorial for instructions on creating clear glass (except for the part about Raytracing and Buffer Shadows): http://wiki.blender.org/index.php/Doc:Tutorials/Materials/Clear_Glass

When I render my model, I get the following result: /uploads/default/original/3X/1/9/1994b2fb8aa3019dcaa8ffc1a7460c4e041c50e3.jpgstc=1&d=1281075010

First of all, there are black splotches which are altogether unacceptable… What are those all about (I have changed the depth for transparency to 7)?

Second of all, I chose red as the colour of the cup, but if its transparency fresnel=5, shouldn’t the red be completely invisible? Why can I still see it?

Thank you very much for your help,
Silentrebel

Attachments


By subtract do you mean boleon?
I remeber them being messy unless you had a dense mesh.
And I assume thats where the problem lies.
Did you recalculate normals, CTRL N
remove doubles, W menu
and check if its a solid object, by selecting non-manifold, also in the W menu I believe. or CTRL ALT SHIFT M

By subtract, I do mean boolean…

So one suggestion would be to create a cylinder with many many vertices?

I read about recalculating normals, but when I select my object and press ctrl+n, nothing seems to happen.

At first, the doubles were part of the problem, but I’m sure there aren’t any now…

I’m not sure what you mean by this point: “check if its a solid object, by selecting non-manifold, also in the W menu I believe. or CTRL ALT SHIFT M” I suspect I haven’t come across it yet; could you explain what you mean in more detail?

I tried an experiment that might be worth mentioning.

I subtracted a cylinder with relatively few vertices (about 30) from Suzanne the monkey and when I made her transparent, it worked as I would expect (I could only see her outline). Of course, in that case, I did not have a cylinder of water inside her hollowed head… So for comparison, I took the cylinder of water out of my cylindrical cup. Here is the result (very similar): /uploads/default/original/3X/0/9/0981afa6454ff1ea078881a186b47e63621363f6.jpgstc=1&d=1281076905

Attachments


this looks…

This looks?

Do you mind posting the blend?

Here it is:

/uploads/default/original/3X/b/8/b83e536165eaa1954f00b7fc34dc9c1edc68cb0e.blendstc=1&d=1281103709

Thanks very much,
Silentrebel

Attachments

2010-08-06-01.blend (186 KB)

do you want to do some glass only and transp i guess
youw ant ot use the Ztransp or mirror and transp to do your glass here ?

do you want to do some fluid simulation here or jsutmfake water inside the glass?

i ahve manye xample of glass i did before but depends what youw ant to do ?

salutations

I’m trying to model a cylindrical glass with some water inside. I suppose the ultimate goal is to also insert a pencil into the water, angle the camera from the top (obviously not 90 degrees) and see the effect of the water’s refraction.

I haven’t considered using any fluid simulation. I thought that, for this simple exercise, I could just make fake water out of a transparent-mirrored cylinder…

Your examples may be helpful, but I really want to figure out what I’ve done wrong in order to avoid this problem in the future; since I am new to Blender, I do not know if I could figure out all that you did by looking at your example anyway.

Thanks,
Silentrebel

I do not know what Ztransp is… So far, I think I’ve been using mirrorness and transparency to model both my water and my glass. Is there an advantage to Ztransp?

Its faster, but it doesn’t look as good.

I don’t think I can sacrifice any more looks; my creation is pretty terrible as it is…

check this out

first glass on ledt done with no liquid refraction
the glass on the righ has liquid with refraction

hope it helps

salutations

RickyBlender, when I open your .blend file, there is not panel near the bottom (with all the buttons for rendering, shading, editing…). I cannot find the option anywhere to restore it. This doesn’t happen when I open my own files…

How do I fix this?

silentrebel, it looks like some of the issues with your render are with your material and some are with your mesh.
You have a lot of triangles, which gives that jagged look along the top edge of the glass.

first try setting your floor material to accept transparent shadows, you find that in the materials section under the shaders tab.

For your glass and water, I think you should be not be using the high fresnel values to see your transparency, instead use the alpha slider under the RGB sliders where you set the color.

And booleans are not likely to give you a clean mesh. You might have better luck with a subdivided cube with a few edits.

Also it looks like your glass was passing through the floor, that would give you problems too with your shadows.

I’ll attach a .blend with a rough example.

Attachments

2010-08-06-01 (2).blend (193 KB)

Thank you, franck3D for all of those suggestions and your example. It sounds very promising!

Unfortunately I’m leaving for a week to go on vacation, so I won’t be able to try all of it straight away, but you can expect an answer in a week’s time.

I really appreciate the support I gotten on this question!
Thanks again,
Silentrebel

sorry i left it in full screen !

just Ctrl- arrow down to bring back four quadrants viewports

should work ok

salutations

@franck3D: In your example, did you use the cylinders I had used (the ones that resulted from the boolean operations)? I just want to make sure that your good result is possible from my modeling strategy…

Thanks,
Silentrebel

In my blend file, the one on the left is your original mesh with new materials and the one on the right is one that I built very quickly.