modelling simple curve

Hello everyone,

just ran into a problem.
I’m modelling a steel rod for a handrail, wich has a geometry of a torus.
I want to make it from a curve that has 208 vertices.
The problem is, whenever I set the resolution higher than zero, strange lines appear connecting random vertices of the curve.
It appears when the curve is selected in object mode.


Attached is the example model of it:
wat.blend (504 KB)

My question is, how to get rid of that behaviour? Does that have an effect on rendering?
Why is that happening? Is that a bug?

Not getting such lines here. Perhaps it has something to do with your graphics drivers and/or blender version, or you’re using Blender that is not directly from blender.org.


What I’m sure though, is that if that is the shape you want, you don’t need 208 handle points to do it, you need 4.

That model was for the comparision.
The object you selected displays here right, as it’s resolution is 0.
The one next to it has a resolution of 14, which has that mentioned issue here.
On win8, with the latest 64bit version of blender -just reinstalled the current one from blender.org.

The 208 is intentional because of other parts of the model.
Not really necessary, but it makes things more organised for now.

Yeah. I tried to change the resolution for both of the objects, obviously. Displays fine for me.

No issues seen here either.
If you beleive it’s a bug report it to the bug tracker (link in blender help menu) with all necessary details

Does that have an effect on rendering?
Have you tried rendering ?

I didn’t try rendering as it is all in modelling stage.
Facing a more complicated texturing before setting the scene.
Was curious if it is a thing to worry about and needed some correction -before moving on.

A bit offtopic, but here is that mentioned texturing problem:
http://www.blenderartists.org/forum/showthread.php?305642-unwrapping-difficulties&p=2455148#post2455148