modelling with curves

i did a model by extruding on a path - curves

and with the curve model i get a relatively smooth corners
then converted to mesh and get sharp corners!

is there a way to have the same for the 2 models curve and mesh ?



Hit the Set Smooth button in the Link and Materials Tab after conversion
and it shuld look the same.

If you need more definition increase the Def ResolU amount in the Curve
and Surfaces panel prior to the convertion to mesh.

Hope this helps,


i know how to namually modify it

the thing is that see pic

when i look at the curve model it looks smooth even if my profile is with sharp corner
or may be there is a setting to show in curve panel ?

when you convert you get what’s on the right with sharp corner and that’s what i want

but i don’t see it in the curve model when created !

so is there a way to see the real model with cuve before doing the conversion
and is there a way to make sharp corner with curves profile i mean twith python may be ?


The DefResolU field (Press F9) determines what your curve will look like when you convert it to a mesh. So lower it to something small for sharp corner, raise to high numbers for smooth conversions.

You can do a CTRL-Z to undo your conversions as well. So tweak the numbers and do converts/undos until you get it the way you like.

seems that the curve model with profile is automatically set to smooth
while the mesh model is automatically set to solid!

so just changing the cuve model to solid makes it look like the mesh model

now i got to find to do that with script !
anyidea on this one ?