Modifier Keys Bug, Blender 2.81 on Mac

Has anyone else experienced this? I’m at my wits end, after searching for hours I still haven’t found a solution to this catastrophic bug. I haven’t even seen any other reports of it.

Today I downloaded Blender 2.81, to check out all the cool new features and see how they fit into my existing workflow. However, as soon as I pressed Shift, to add in a new object, the contextual text next to the mouse icons in the bottom row disappeared, and my entire keyboard froze. Not system-wide, mind you. Cmd+Space for example worked as normal, just inside of Blender nothing worked anymore. Well, not quite nothing: Using the gizmos from the left tool bar works to scale, rotate and move, using the mouse. I can also navigate the UI, but navigating the 3D space doesn’t work. To make the keyboard responsive again, I have to click on another program icon in the dashboard, then come back to Blender.

This happens with all modifier keys, i. e. Shift, Control, Option and Command. Obviously, this makes Blender unusable, however, I need Blender for my work. Can anyone help me out with this?

Oh, and by the way, this propagates through all Blender versions. I tried reinstalling version 2.80; the bug was still there. Same with the new 2.82 version. Any ideas what the reason could be?

I’m having the same issue as you, I think.
I reported this bug on