Modular Tree

add-ons

(Fatesailor) #321

Great work! Many thanks for this so precious add-on!


(Maxime) #322

Added a color ramp sampler operator (similar to substance designer) to quickly modify the color of the procedural materials. The new release should be online tomorrow or the day after.
http://pasteall.org/pic/show.php?id=7e7a5d898615a3fda33f5d6811e07527


(3pointEdit) #323

Wow…:eek:

I go away for just a little while and… this is amazing


(n1k) #324

Maxime, you are one awesome dude! Excellent work.


(theApe) #325

You´re blowing my mind right now…


(burnin) #326

https://media.giphy.com/media/ernsyfGZTGtJC/giphy.gif


(Maxime) #327

Twig operator with three leaf type (I will add more in the future) :



(Jaydead) #328

I got a feeling this will become a very popular add-on. Excellent work!


(enricoceric) #329

Man, you rock !
This smells so good :wink:


(Oyster) #330

is the leaves images? if so, can the community join and supply some? and how?


(Maxime) #331

The leaves are objects with images, you can supply some by putting them on blendswap and notify so that I can add them :slight_smile:


(JustinBarrett) #332

I see maple, birch and oak…do you have any plans for spruce or pine…just curious.


(Maxime) #333

I do have plans to add more materials and leaf types.


(Maxime) #334

Here it is, after quite a bit of work, the new release !

You can download it from here.

I have started to write the new documentation, I will finish it and complete it with a written tutorial soon !

As this is mostly new code, bugs and errors are to be expected, please let me know of anything you stumble on while using the addon, on this thread or directly on github.

Any feedback is good and very welcome, the addon wouldn’t be what it is if nobody had told me what didn’t work and what did, so feel free to share your thoughts :slight_smile:

Lastly, the addon is free and always will be, I strongly believe in the open source philosophy, but I have decided to add a donate link for those who can and are willing to support the development, and the time I put in it. donate.

Happy blending everyone :slight_smile:


(urkokul) #335

Very thanks for the update of the great addon and good luck


(zcaalock) #336

after clicking install addon from file it doesn`t show up on the list

edit:

it broke somehow sculpt speed addon :frowning:

"Traceback (most recent call last): File “xxxxxxxxxx\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\speedsculpt_v_0_1_8\ui.py”, line 1006, in draw
Options(self, context)
File “xxxxxxxxx\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\speedsculpt_v_0_1_8\ui.py”, line 195, in Options
for mod in bpy.context.active_object.modifiers:
AttributeError: ‘NoneType’ object has no attribute ‘modifiers’

location: <unknown location>:-1"

and i cannot get it to work now even after removing modulat tree addon from folder


(Maxime) #337

I have the same issue, it seems that somehow the addon is broken when downloaded from the release page, however it works well when downloaded directly from the master branch.

I will change the link to the master branch, try rebooting blender and then reinstalling both speedsculpt and the correct version of modular tree, tell me if that fix things ?


(zcaalock) #338

new error :confused:

Traceback (most recent call last):
File “xxxxxxxx\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\wazou_rmb_pie_menu_2_2_3\operator.py”, line 2736, in poll
if obj.type == ‘MESH’ :
AttributeError: ‘NoneType’ object has no attribute ‘type’

and the same error as before

location: <unknown location>:-1


so, how do i make tree?


(Maxime) #339

It seams to be the same kind of problem, have you restarted blender ?


(zcaalock) #340

i restarted and reinstalled addons, same error. See the screenshot two posts before