Modular Tree

add-ons

(Maxime) #381

they specify specify which part of the tree to apply the node to.
If the selection input is not connected, the node will be applied to the whole tree.


(Maxime) #382

Thank you all for your feedback, I currently don’t have time to work on the addon, but I will after my exams !


(AFWS) #383

I fixed a issue in the “preset addon”, where it didn’t save a setting for the grow node. Also, it now saves presets depending on the input being used.

Edit:
Made more changes, see my post above.


(AFWS) #384

Not sure if it’s suppose to do this ,but I noticed it doesn’t always connect at two resolutions.
Also, what does the inputs on the “Trunk Node” do? I have tried a hundred different things and can’t tell that those inputs do anything.


(Schillem) #385

Thank you and good luck for your exam.


(zcaalock) #386

is it possible to make boundary in shape of cube or sphere?


(melvi) #387

Hi, is it possible to move the tree while tweaking the node parameters? Sometimes u might need the tree in a particular location, and compare the features u are tweaking with the sourrounding elements.
Each time, I tweak the parameters, the tree goes back to the origin center (0,0,0)

Thanks


(CombatBlob) #388

Thank you for all the work you’ve put into this addon @Maxime :smiley: Can’t wait to see where this is going. Thought I should share this here:


(Ben) #389

Hey Maxime, loving the results in this thread from your add-on! I’m running a Mac on Blender 2.79 and attempting to install the zip file but it has not worked for me. Terminal returns the following lines:

fake_module: addon missing ‘bl_info’ gives bad performance!: ‘/Users/BH/Library/Application Support/Blender/2.79/scripts/addons/tree_creator.py’
Modules Installed () from ‘/Users/BH/Downloads/modular_tree-2.8.2.zip’ into ‘/Users/benhoo/Library/Application Support/Blender/2.79/scripts/addons’

Is there something I may have missed? Many thanks


(AFWS) #390

Any of you guys know how to use wind? I tried the “Wind Operator” ,but just the armature moves. I also tried “Fast Wind” ,but it gives a error.

Edit:
I think I figured it out.


(aghandwork) #391

Hello! Sorry…but how to use it? Any tutorial please.


(jachtarfranko) #392

Yes please, one youtube tutorial would be great.


(kabu) #393

Same here:

It takes joining them someway (bridge edge loops?)


(Bradley Schwartz) #394

This is a wonderful tool, and clearly very powerful…but holy crap you need some documentation. For instance, why does “Radius” seem to affect the number of branches?? A simple description of what each setting does would go a very long way.

But regardless, this is light years ahead of the Sapling Addon. Very nice work!


(melvi) #395

Any way a final tree can be created from the node system. Finalised with all the tree parts merged into one one mesh including the leaves?


(Atom) #396

I’m having problems getting the AddOn to work.
I downloaded the AddOn from GitHub. Install from ZIP does not work. The GitHub file name still has the period error in the file name so I renamed the AddOn to “modular_tree-3” and copied it to the AddOn folder for Blender 2.79. The AddOn does show up under User Preferences and I have enabled it but I don’t see a Make Tree button at all. I just see a Make Twig button, that does make a twig mesh.

Is there a way to get the full functionality for this Addon?


(Jakub Vondra) #397

You should have new node tree type available in the Node editor.
Capture


(Maxime) #398

Hi everyone,
I see all your questions and really want to answer to all of them, and make those much needed tutorials, but I just don’t have much time. I am in the last year of my studies, and it is quite time consuming. I will absolutely make sure to port the addon to 2.8 once it’s there, and make a real tutorial, but I can’t guaranty anything until then.

Thanks for your support, even if I’m not very active, it mean a lot !


(Atom) #399

Thanks for mentioning the node editor. I did not realize that is where the object resides. I guess I was looking at an old document that showed a Make Tree button.

But I still can’t generate any tree from the node menu. All items are greyed out.
tree_menu

Ah…I have to create a new NodeTree first.


(Atom) #400

So how do I add roots?
I added a trunk thinking I could use a negative attract and it crashed the AddOn. Other negative values also seem to crash the AddOn.