Modular Tree

add-ons

(Jesus) #506

very good progress has been made with the complement, I just tried it and I feel that I have much more control in the tree.


(Jesus) #507


(Jakroval) #508

Please, some body explain how to use Mtree in Blender 2.8


(enricoceric) #509

I noticed that there were no branch starting from the end of the trunc, is there a way to generate them ?
Also it’s hard to generate small branches, often adding a third branch node to have small branches doesn’t change much, a few small branches are generated a the top of the tree but not in the bottom branches, any solution for that ?
Thanks again


(Jesus) #510


(Jesus) #511

every time I understand better how it works, I love it haha


(Maxime) #512

You can now add and load presets !
The option to do so is located in the n panel of the node editor.

I added only one preset for demo, but I will add more. The goal is to have a lot of presets so that creating a tree is very fast : select a preset, change some values and voila !


(Peetie) #513

Is that in the 2.8 version as well? I couldn’t find this option so far. Do I have to select a particular node?


(Maxime) #514

Yes it is in the 2.8 branch, I added it an hour ago


(Peetie) #515

I see it now. I made added a few presets, but when selecting a preset it doesn’t change the nodes / doesn’t add a node tree. In other words selecting a preset seems to do nothing.


(Maxime) #516

does it work when you click on load preset ?


(Peetie) #517

I see an option to execute a preset in the node-editor:
NodeTree

  • I click on the node: Tree Parameters
  • Press N
  • And then see 1 till 3 in image.
    But nothing happens, also no error message in console

Update:
Ah, I found the other Tab: Mtree in the N-panel, and there I see the option to load and save presets.
But when I try to save a preset, I got this error:


(marcatore) #518

I’ve tried the 2.8 branch.
It seems working but I have some questions:

  • everytime I changed something I have to delete all the generated meshes and the execute tree?
  • Presets seems not working both load and save. About loading, the preset is empty and the old oak preset is not visibile (actually the json file is in the preset folder of the addon.

(zcaalock) #519

is there option to limit growth to shape? i want to make hedge and want to restrict growth to rectangle


(Maxime) #520

I fixed the presets error, it should work now, please tell me if it still doesn’t :slight_smile:

In order for the tree objects to be replaced after changes, select it before executing the tree.


(Maxime) #521

Not yet, but that feature should come back at some point


(Kumaran sip) #522

How to download Graswald free sample,can you sent me the link pls.thank you.


(Peetie) #523

Got the latest for Blender 2.8 on github:
When clicking on Execute tree (Only have default branchnode):

When clicking on Save Preset:


(mak485) #524

while executing twig node, following error occurs…

Traceback (most recent call last):
File “/home/mak/.config/blender/2.80/scripts/addons/modular_tree-blender_28/nodes/twig_node.py”, line 88, in execute
node.execute()
File “/home/mak/.config/blender/2.80/scripts/addons/modular_tree-blender_28/nodes/twig_node.py”, line 66, in execute
leaf_candidates = tree.twig(self.radius, self.length, self.branch_number, self.randomness, self.resolution, self.gravity_strength, self.flatten)
File “/home/mak/.config/blender/2.80/scripts/addons/modular_tree-blender_28/tree.py”, line 175, in twig
self.grow(1, 1, 1, 0, resolution, randomness/2/resolution, 0, .2, 0, 0, 0, .1, 1, 0)
TypeError: grow() missing 1 required positional argument: ‘selection’


(Maxime) #525

First error occurs because there is no trunk node. This behavior is expected, i will add safeguards to prevent it in the final version.

Second error is strange, I can’t reproduce it, and it does not seem justified. I will investigate !