Modular Tree

now i have and i can say that it isn’t working

And you used either the windows or linux links from this release ?

i have used the windows version

Oh I just noticed that the mtree library is missing from the zip
I’ll fix that !

1 Like

thx :3 and let me know when you fixed it

Alright there was some magic involved, but it should work now !

4 Likes

I have version 3 on MacOs 11.4. MT does not show up in the tools tab as stated in the preferences nor does a editor appear when enabled.

V.4 appears to not be available for Mac, is this true?

If you look at the previous messages you might make the version 3 work on blender 2.92+ .

The version 4 is not available on mac, but that could change depending on how easy it is to compile mtree for mac-OS.

Thanks @Maxime I have same problem like @Slinc_HD . Bt now the problem is solved. Thanks again for the addon.

it is fixed :smiley: thx now i can make super cool trees with bether topo :smiley:

Another Mac user here, chiming in to say I’m looking forward to trying V.4 when you port it to MacOS, and that this add-on leaves me :star_struck: !

Works now. Thanks.

The addon now compiles for MacOS, I can’t test it but hopefully it’s working :slight_smile:

3 Likes

Does the tree mesh created from the addon generate its own uvs or you have to create them manually in 4.0 alpha version?

no uvs yet, I’m working of it

1 Like

Ok. Thanks :+1:

I added a “radius override” node that estimates the radius of the branches after they are generated:

21 Likes

How do you add the leaves?

Can’t wait to get the full wersion of Mtree 4

1 Like