Module doesn't exist


(blender_man) #1

hey all,

I keep on gettin this message when i run most scripts, i understand that blender doesn’t come with full python implemetation and you have to install a newer version of python (which i’ve done) and then change the enivronment variables(I’m using windows xp) but i don’t really know what to change them to.

any help would be great!!

PS
I may be completely wrong!!!


(Enzoblue) #2

This from Jan,

Test your Python installation:

Double click python.exe in Explorer:
The answer should be something like this:
Python 2.0 (…)

Type “copyright”, “credits” or “license” for more information.
>>>

Check your PYTHONPATH. Still in the Python interpreter type:
>>> import sys
>>> print sys.path
The answer should be something like this:
[’’, ‘c:\python20’, ‘c:\python20\dlls’, ‘c:\python20\lib’, ‘c:\python20\lib\lib-tk’]
>>> (to leave the interpreter press CONTROL+ZKEY)

Try the same within Blender: Start Blender, open a text window (SHIFT+F11), create a new text (ALT+SHIFT+FKEY), type in the following lines:
import sys
print sys.path
Start the script with ALT+PKEY and watch the output in your shell.
To make sure that your PYTHONPATH is correct you can edit your autoexec.bat file and add the following line:
set PYTHONPATH=C:\PYTHON20;C:\PYTHON20\DLLS;C:\PYTHON20\LIB;C:\PYTHON20\LIB\LIB-TK


(blender_man) #3

Thanx loads :smiley: :smiley: i’ve the problem for ages and just thought it was me, i did everything except i added an environment variable instead of actually editting the autoexec file coz i’d probably delete something

thanx again

PS whats the best or most problem free version of python to use with blender(i’m already getting probs due to conflicts with versions) :wink:


(aayers) #4

For Blender 2.23, use python 2.0.1
For Blender 2.04, use python 1.5.2

For versions in between … I’m not certain. But I think for version 2.14 and greater, python 2.0.1 works fine.

Can someone check that.


(totmacher) #5

py 2.2 won´t work.
the py c api has changed, the c modules has to be recompiled.
for 2.1 i don´t know.


(theeth) #6

Python 2.01 is really your best bet (for 2.23).

Martin


(bmax) #7

what the… 2.2 works fine on my win98 and blender 2.23, c’est vraiment etrange…

Au revoir,

Tôm ( :wink: )


(totmacher) #8

try to import for example the socket module.
if this works let me know
i am using 2.25