Molecular + for Blender 2.8, 2.9

particle solver for Blender 2.8+

Originally based on molecular addon from pyroevil. https://github.com/Pyroevil/Blender-Molecular-Script
and the effords of PavelBlend and Scorpion81 for maintaining compatibility with Blender 2.8+. https://github.com/scorpion81/Blender-Molecular-Script

This is my extended version of the addon adding a create panel to be able to fast setup a scene.

I cleaned up the code and moved the molecular+ panel to the physics section of blender, where it belongs.

Added a n-panel to get fast access to setup / recalculation.

More info on my website. http://q3de.com/research/molecular/

Join my discord

This great addon and all the work that pyroevil did needs a place for futher development !!
Let’s build a community. If you are a developer contact me.


12 Likes

Thanks for sharing.

Hi u3dreal,

I’ve been hoping someone would revive this great addon. Thanks for working and sharing this!

Cheers and stay safe!

Hi ! First of all, thank you so much for your work !! I’m a biochemist working on molecules renders/animations and this addon is extremely important for my workflow, please keep up the good work !
I’d also like to ask, is that a thing too with your version of the addon ? :
Screenshot_20210217_040654_org.mozilla.firefox

As a subsidiary question, is there any particular ways of getting improved perfomance that you recommend ? (thus more particles simulated)

I haven’t really tested this case. I found that the bottleneck is Blender here since getting and setting the particles is only single threaded. molecular is multi threaded … you can see this in the console comparing Blender and Molecular time.

But just test it. It should be almost the same since this is more or less the original cpython code.
If you want to take part in discussion hit over to the discord.

Understood, thanks for the infos.
BTW the invitation link to the Discord is invalid, could you please reissue it?

I don’t know if it’s only me but the video you post aren’t working, not this last one just now nor the one from 3 days ago

that is strange for me it works on Chrome, Safari and Firefox …

No video over here, tried FireFox (default), Chrome, Edge, but … . . … Internet Explorer :flushed: shows the video :thinking:

OK i uploaded them instead of linking from my site … does it work now ?

Yep that fixed it, thanks!



Version 1.1.3

  • about 30% speed improvement !! on Blenders side.
  • new Emitter object
  • new inspect panel
  • on screen scene statistics
  • added python 3.9.2 version for blender 2.9.3+
  • many fixes i may have forgotten
  • get it here

If you always want the latest ( that might include some bugs :slight_smile: )
github actions

2 Likes


Hi! I’m testing latest molecular+ (1.1.3), and having an issue that shown on video. I’m creating a plane emitter with uv spheres and at the start of simulation particles just bounces from each other and fly away. I’ve compared the same setup with original molecular 1.1.2, and there particles behave much more predictably, just starts to fall down. I need to mention that for molecular+ i’m using latest blender 2.93 alpha, and for molecular 1.1.2 - 2.92, because it gives me an error when i try to install it on latest. This issue appears only in emitter type, not 2d or 3d grid. But if i crank up randomness of a grid, then problem comes back. I think it has something to do with particles, that appears at the same place and instantly bounce from each other, and solution is to create a grid with no intersections. But in my case i need a random particles appear, without noticeable pattern… Now i need to stick with previous molecular for this, but your version in much more handy to use, so maybe there is solution for this. Thank you.

Hmm you might wanna try the latest … here
https://github.com/u3dreal/molecular-plus/actions/runs/714432560
… i fixed alot of stuff. And there was a bug with alive state … so they might bounce of particles that are not yet born.

Also head over to the discord … makes things alot easier to share.

https://discord.gg/tAwvNEAfA3

Hi u3dreal,

in Version 1.1.4 the wild fly away is gone, but the Self Collision doesn’t work.
I hope I did everything right, this is my first attempt with the + variant of molecular.

I am on Win 10 and Blender 2.93.

no-self-collision.blend (592.3 KB)

Hello
molecular only supports sphere partciles and the physics will act accordingly.
When switching viewport display to point and setting it 1/2 the size of the particles … this should be the same in 2.93 and on. It works fine.no-self-collision.blend (1001.4 KB)

Also make sure to rotate the plane and emit downward. Also adding more particle dampening will help with flyaways.

Hi u3dreal,

first of all, thank you very much for further development the Molecular Add-On and for your quick answer.
Is it planned that the Self Collision also works with other objects?

These “switching viewport display to point”… What good would that do?
It only gives the impression (in this case) of something that does not correspond to the end result.

I don’t think molecular will be able to solve mesh collision anytime soon.

These “switching viewport display to point”… What good would that do?

It just visualizes the size of the spheres that are used to calculate collisions.



update 1.1.4

  • stop button
  • weak map to control particle link broken by texture from particle texture slot[0]
    demofile
  • fixed mutithreading
  • many fixes i may have forgotten

github

8 Likes