Moleculars physics

Hi Pavel,

I have the same error as steve.

Traceback (most recent call last):
File "E:\Blender-28\scripts\addons\molecular\operators.py", line 60, in execute simulate.pack_data(True)
File "E:\Blender-28\scripts\addons\molecular\simulate.py", line 18, in pack_data for psys in obj.particle_systems:
AttributeError: 'NoneType' object has no attribute 'particle_systems'

Blender from today: blender-2.80-a813e259d630-win64
Win 7 Pro

particle_systems-no_attribute.blend (1.1 MB)

Very happy to see this one ported. Great job

I don’t know how I missed this. 2.80? Fantastic. Thanks, @Pavel_Blend

Thank you for the great addon!
Just my scene made in Blender through Molecular Script and my addon Bravais Lattices Creator
Atomic visualization of HSS in contact with synthetic diamond crystal


Bravais Lattices Creator:
https://blenderartists.org/t/bravais-lattices-creator
http://alexiy.nl/category/blc/
1 Like

a few fixes for the molecular addon, should work in 2.80 now again :slight_smile:

6 Likes

Thank you scorpion81,
is working again.

Unfortunately, I can’t even handle a simple collision.
The objects (cubes) go into each other.
From picture 147 the cubes move very fast away from each other?

Is it a bug or a mistake on my part?

Are there any basic tutorials for Moleculars physics?

Blend:
http://pasteall.org/blend/index.php?id=51935

Blender from today (741641f4c3b8-win64)
Win 7

I have made a fix which correctly resets the cache if a molecular re-simulation is being invoked. I tested your blend with that version and it showed different collision behavior compared to the bake. This is in 1.0.8 whose source is on github already. I also made a version bump inside the cython binary (but no further change). I will post the “proper” release zips later. In the meantime you could download the latest python files from github and use the existing .pyd file in order to test.

Update: 1.0.8 release zips are up ! :slight_smile:

Some older video tutorials…

4 Likes

That’s great!

Works perfectly, only very few overlaps in the objects.
I’ll have to do a little work on the parameters.

Thanks a lot for the script and the video links, scorpion81.

Took me a long time to find a working version of this script, all the links to it online only lead to the old devs’ page where it runs out at 1.0.7 (which totally doesn’t work).

Your version seems to work well though, I really hope you keep it updated in the future as Blender would be completely crippled if they ever lost this script. Honestly don’t know why it’s not in the basic toolbox like it is with C4D.

1 Like

Does it work on the newly released Blender 2.8? I tried but am getting an error when baking the simulation

It worked for me, but you have to make sure you’re using the actual new version. It’s a pain to find, because pretty much all of the links for Molecular take you to the original github which only has out of date files. You need to be on 1.0.8

Thanks for the tip! Where do I find the new version?

1 Like

Hey guys, did anyone get this script working with baked UV’s from emmiter? And if so, which version of blender and of the script did you use? I tried downloading various corresponding versions of this script and blender (that were supposed to work together) but i always got stuck right before baking process on python errors.

Thanks in advance to anyone who is willing to help me.

PS: This script is amazing

Thank you. Got it to work few times, but now getting some bake errors.

Yeah, baked UV’s seems to cause the bake to end in error.

i get the same error as you when i select “Set global UV” and then check “bake UV at ending”

and when i try to select "set active UV(current “UVMap”) i get this error

here is my .blend file if anyone wants to check it, maybe it does work for others and we are doing something else wrong

http://pasteall.org/blend/index.php?id=52124

help is much appreciated

Are force fields not working wit4h 1.08?

I am getting an error "ImportError: cannot import name ‘core_37_64’ from ‘molecular’ " when I try to activate the addon.

Hello,

I made a few fixes for the python errors mentioned here and also packaged a new release zip (1.0.9) per OS.

Didnt recompile the binary since there are only python changes now. So if the binary reports still 1.0.8 as version, this is fine… (didnt bump its internal version), but the addon should be 1.0.9 now

Regarding the force fields, they should work, just tested here with force, wind and vortex and molecular. The simulation did definetely respond to the force fields.

Regarding the binary not being found, make sure to install the proper release zip for your OS. It should contain the binary (which is not inside the github source repo, but its sources are there under “source”)

Edit: I also have 64 bits versions only (precompiled)

Edit 2: seems to work :slight_smile:

Remarks:

  • only in cycles
  • only in rendered viewport and render
  • need to re-bake the sim for UVs after loading (not persistent, it seems)

test_UV_molecular.blend (835.1 KB)

Edit 3: same blend, but with 30x30x30 particle grid:

5 Likes