More Newbie Questions

I have two problems while modelling in blender:

  1. When I´m trying to subdivide polygons with “Knive Subdivide” blender is doing fine with the first polygons (just cutting them in half), but somehow cuts the last polygon in two triangles instead of just in two halves. Where is my mistake?

  2. After working with blender for a while (like 15 minutes or so) whenever I press “A” a counter will start instead of vertices being selected/unselected. What is happening?

Can anyone help?

  1. If you cut a plane’s edge, new faces must be created to make sure there are no ‘floating’ or overlapping edges and vertices. If you cut through the whole plane, this problem will not occur. I can’t explain it better. You need to understand how faces/edges/vertices work together…

  2. You have probably pressed ALT as well? What you are experiencing is an animation, where the counter is the frame counter. Maybe some harware issue locked your ALT key. Do you have an ATI card?

no mistake, a blender “limitation”: it can only handle 3- or 4-sided polygons. so, to avoid that, it automatically makes triangles where nececcary.

this has IMO nothing to do with how long you work with blender. you probably pressed ALT+A, which starts the animation playback in any viewport and shows a quadratic frame-counter. make sure you press only A for selecting all/deselecting vertices

marin

no mistake, a blender “limitation”: it can only handle 3- or 4-sided polygons. so, to avoid that, it automatically makes triangles where nececcary.

Thank you, I think now I know what went wrong. When I cut edges in half blender sets new vertices. This means I will have five vertices in the polygon next to the last edited one and thus a five-sided polygon. Is that correct?
(did anyone actually understand this explanation? oh, my english sucks…)

this has IMO nothing to do with how long you work with blender. you probably pressed ALT+A, which starts the animation playback in any viewport and shows a quadratic frame-counter. make sure you press only A for selecting all/deselecting vertices

This is probably what has happened. How do I get out of the animation mode again?

hit ESC

Look at https://blenderartists.org/forum/viewtopic.php?p=263906#263906

Thank you, that fixed it.

But I still can´t get the cutting working correctly. No matter what I try, one of the polygons will be cut in triangles instead of a 4 sided polygon, although all the polygons I want to cut are 4 sided. Maybe I´m too stupid for this, but I can´t figure out what I´m doing wrong.

It also seems, like some of the cuttings-points (new vertices) I´m setting simply disapear when I hit enter to confirm the cutting.

As solmax said, Blender can only handle tris and quads, nothing more than that (called ngons in the 'biz)

When you cut a quad right through, it’s easy to make 2 quads:
http://www.cs.newcastle.edu.au/~c3018900/11.png -> http://www.cs.newcastle.edu.au/~c3018900/22.png

But if you only cut one side the face now has 5 sides:
http://www.cs.newcastle.edu.au/~c3018900/33.png

There’s two ways to get around this. One is to leave the quad as it is, and ignore the extra vertex (that’s how I made the screenshot above) but if you move any verts you see the problem:
http://www.cs.newcastle.edu.au/~c3018900/44.png
This hole can cause many problems - you can’t move the verts, and you get seams and/or gaps with other tools. And you can’t just patch this hole with a triangle, because then when the vert is where it belongs you have a zero-width face, which can also cause problems.

So the other alternative is that every polygon can be turned into triangles, so do that to our pentagon:
http://www.cs.newcastle.edu.au/~c3018900/55.png
Notice that you can still move the verts around the mesh is still whole:
http://www.cs.newcastle.edu.au/~c3018900/66.png

I hope this answers your question.

And in answer to your next question of “why doesn’t blender support ngons” the answer is that the tri/quad is too ingrained in blender’s source to adding n-gons would require a massive rewrite of large quantities of code, and no-one could be bothered.

Thanks a lot for going through so much trouble to help me, now I got it working the way I wanted it.

Btw: How did you know what my next question would be ? :wink: