Mother of perl! I am done! Its done! GUI CREATOR!!!!!!


It is 2 in the morning, I have been working for… oh, about 6/7/8 hours? Anyway, I am so frantically proud that I am litterally dancing around the room!

This version of my GUI Creator has SOO many new features. Look at some of them:

Full mouse control. (You don’t even need to use the keyboard if you don’t want to :smiley: )

Bitmap loading with my own integrated bitmap loader!!! The best part is that it imbeds the bitmap into your compiled script, this way there is ABSOLUTLY no dependancies.

Object Names!!!

Bugs got fixed.

A new cool little popup menu.

And… it is backwards compatible! This way, you can load up any projects you may have been working on without any worries.

Oh I am soo happy that I finished this!!! Please PLEASE tell me what you think!

Right now I am going to bed.

malefico… should I e-mail you my portrait now or later? :smiley: :stuck_out_tongue:


Please note: This script is self registering in the “Misc” catigory if you just put it in “.blender/scripts”

:smiley: :smiley: :smiley: :smiley: :smiley:

WOW :o :o :o :o

Really impressive new version ! I tried the mouse control is pretty nice, also noticed the different colours for scaling up/down, and moving. The image browser is a great addition also even when it only supports 24 bit BMP.

I got some problems figuring out how to move things with the mouse, seems like a have to click and drag, but sometimes when clicking on sliders I enter control edit mode instead of the grab mode.

Noticed that middle button swithc from XY to constrained X or Y, neat, really neat.

Well, you could send me your portrait via email, no doubt ! :smiley: :smiley:

Glad you like it. When you click on some controls to select them, such as a String, or a Number it is just Blender going into that mode, it’s not my fault. The best way to select objects is not to click on them, but to press Space and use the Select object… function.

By the way, I am not sending a portrait! :stuck_out_tongue:

Has any one found any bugs yet?

Is malefico the only one using it? :o

woa coolness… No bugs yet but a few idea questions…

With python in general can a box be moved with the mouse ? and or have control handels for resizeing ???

And one other thing how does one asign a button or a scroll slider and such to a function in a script?? I would like to use this to give the little scripts out there that have no buttons a few buttons if even just play buttons so I do not have to constaly select them from a contex menu…

It is simple to assign scripts with no GUI a GUI. Just make the GUI, click “Compile”, select a file name, lets pick “”. After it compiles, load the script up in your fav’ text editor, and scroll down to the lines that say “Place your code here”, then simpley do what ever the heck you want “There”. :smiley:

Glad you’re done :smiley:

Desired Feature:

Oh, and by the way, any chance you can select multiple objects so that they can be moved as a unit? If it does this already, and I just don’t know how to do it, sorry.

Bugs Detected:

The script seams to implode when you try to select an image that is not 24 bit. It displays the error, then … poof. The limitation can be dealt with, but it is easy to pick an image that is not 24 bit, so the error trapping should preclude a crash. This bug is repeatable every time.

When I was playing with a slider … trying to slide out to a maximum … doesn’t matter what the maximum is … (holding the left button down and dragging) … Blender crashed when the left mouse button was released after having reached the maximum value. This bug is repeatable every time.

Just so you know, I’m using the stable release of 2.34 on an AMD Athlon 1 GHZ using Windows ME and a full 2.3.4 python install.

<edit> Yes … sorry I forgot to mention that I definitely like your script and can see how it’s functionality will be quite useful to me. :smiley:

I dont see it neither. anyway good idea

same here. cool script anyway! it totaly rocks dude!

It’s very nice to have a fully funtional GUI designer right inside Blender. Good Job!

The only “error” I get is when I load up the script- My computer beeps about 8 times and the Selection slider is scrolling off the screen, but its value is 0. I believe the slider is having a division by zero error.

Windows, Blender 2.34

Alright, I just posted a new version. I haven’t added two features that are pending yet (Multiple selct and a Page control). Please look at the change log at the top of the file for a list of features and bug fixes.

Please Enjoy!!! :smiley:

Hey thanks RipString! I was wondering what caused that beeping bug. It doesn’t happen in Linux, so I never noticed it until I booted into Windows, and then I never gave it much thought. I just updated the script again, I disabled the selector until there are objects to select. Tell me if it still beeps.

Enjoy once again!

By the way. I found the “beeping bug”. It is in the Blender source, in the debug statement that says “DeprecationWarning: integer argume
nt expected, got float”. The string isn’t NULL terminated, and so it spits out a slew of poo (it rymes!), and in the poo is some \b characters, which happen to be “system bell”. I’ll report this to the Blender bug tracker.

I looked in the source for that warning and couldn’t find it. In what file is it?

Double quoted strings are NULL terminated implicitely, you don’t have to do it explictely. (unless I didn’t understand correctly what you meant).


No no! I meant in the C source code of Blender itself!

Yeah, that’s what I meant too. :slight_smile:



That still doesn’t tell me what C file from the source code generates this warning. :wink:


Alright, here is version 2.0, probably the last release. I know I am not going to do any more big things, altough I probably will fix bugs.

You can’t even imagine! I ripped up SOOO much code. I had to redo almost everything to allow multiple selections and pages!

Please view the change log for a list of new features. If you have any trouble figuring things out, please e-mail me, [email protected]

Or you can always post here. :wink:

Please inform me of any bugs. PLEASE tell me if you ever do write a GUI with my script, I would like to see it. Also, PLEASE let me know right here in this thread what you think. I have put MANY! hours into this script, so I would like a little bit of comments, if you don’t mind. :smiley:


I just thought I would quickly whip up a tut here. I thought maybe some of you might get confused about the new “Pages”.

Open up my GUI editor. Click “Add”, select “Page” from the sub menu. You’ll notice that now the “Selector” says “Page 1”, when ever you add a page to your project, you automatically go to that page. Now, click “Add” and select “Object” from the sub menu. Then select a “Button”. It will appear on the screen above the red line. Put the mouse cursor above the red line and to the right of the button. Now click the left mouse button once, and move your cursor upwards. Move it to: X = 8, Y = 32. Click the left mouse button again. Now click on the left side of the slider under the red line that says “Select page #”, I call this the “Selector” (Note: Before version 2 this was used to select objects, so don’t get confused, because now it selects pages instead). This will bring you to page 0. When on page zero, add another button. This time lets to it differently. Go up and place your mouse cursor about where the button on the other page is, don’t worry, it doesn’t need to be exact. Now click with your right mouse button, or press space. When the “Popup-menu” appears, select “Add…”, than “Object” than “Button”. This will place a button right where your mouse cursor is. You’ll notice how ever that it didn’t snap the button to the gird, maybe I should change this? Anyway, don’t try to change its position by typing, X=8, Y=32 into the position boxes. The position boxes are relitive to it’s starting point, so that doesn’t work. The way to do it is to grab it with the mouse, move it down to 0,0 and set it there. Then you can type 8,32 into the position boxes. Allot harder that just using the “Add” button huh’? Anyhow, I just wanted to do that to show you it CAN be done. Now for the pages. Add two “Toggle” buttons. Place the first one at 0,0. Now select it and press “Shift+d”. Move the duplicated toggle button to 64,0. After this is done, name both of them “Page 1” and “Page 2” respectively. Now select “Page 1” and click the “Toggle Page” button down in the properties. Now select “Page 2”, press space, and select “Send to page…” from the popup-menu. Now select “Page 2” from the 2nd popup-menu. This will send the toggle button “Page 2” to page 2, and then bring you to page 2. The reson I did all that was to get the toggle buttons alligned. I think it is easier to get buttons on different pages alligned that way. Anyhow, now on page 2, select the toggle button “Page 2” and click “Toggle Page”, which tells my compiler that “this toggle button is the handle for this page”. Now save your project by clicking “Save” and typing “myproject.pjr” -> Save. Now compile your project by clicking “Compile” select and click “Compile”. Now goto the scripts window, select File->Open, open, and press Alt+P

Any questions, e-mail me or just ask.


superb. it works fine here… the bugs mentioned with the sliders has gone. superb :smiley:

Amazing !!! Thank you very much, the script rocks !!! :smiley: :smiley: :smiley: