Motion blur on particles

Hi. I’m new to Blender and have little experience with particles. I’ve created an animation where I have particles being emitted from an object as it dissolves. I’d like the particles to have motion blur but can’t get it setup and working.

I’ve tries using Cycles motion blur, and vector blur in the compositor but neither have worked.

See still render attached.

Any help gratefully received :slight_smile:

I’m still not getting anywhere with this one. I modelled the objects with real world dimensions, so is Blender struggling with the scale maybe? The pill is only 1cm in length. Would I need to adjust something to compensate maybe?

Well I’ve tried everything and this just doesn’t work. I’ve found that other people have got motion blur on their animations with particles emitting objects. I’ve cached the particles and still nothing. Deformation motion blur turned off and on. Updated to 2.9. I don’t get it. The sequence is going to look bad without the motion blur. Am I missing something?

Bump! I am running in the same issue.

I’ve notived it does render when you render a movie.