Motion Tracking not working

Hi there,

Not sure if I am posting this in the right place, but here we go.
I have problems solving the camera motion tracking. I’ve have taken the correct steps, in order to do my motion tracking.

  1. I have quality footage (transcoded to apple pro res 4444), with markers (white dots) that I am tracking.
  2. I’ve added all the needed markers to both the tracking area (with the physical track markers that I recorded) and foreground and background markers in the video.
  3. I’ve added the correct Focal Length, from the specifications of my lense (18 mm), have the optical center at (960.000 & 540.000). On top of this the Camera presets are set for Canon 7D which I recorded my footage with.
  4. When I track the selected markers I get a Solve Error of: 0.5996 which should be perfect for my tracking.
  5. I set the Keyframing from 50 to 150, where I basically have some movement in my recording. (Start 1 / End 200)
  6. Now here comes the problem, when I try to solve the Camera Motion, I get an error which reads: “Some data failed to reconstruct (see console for details).”

From there on, I can not do anything. The thing that is odd to me is that I only have 4 icons in my right tab, which are the “Render”, “Scene”, “World” and “Textures” and nothing else. I should be able also to see the rest of the icons but they are not there. I presume that if the “Solve: Camera Motion” worked correctly then the other icons would appear? No?

I have tried numerous times to tweak every parameter I could find, but still no luck.
I love the idea of working in Blender especially doing motion tracking, as it seems so intuitive, so therefore I would appreciate your help and guidance.