Motionblur for composite

Hi,

I have to render an image sequence with alpha for compositing with a real video.
I use “Key” in rendersettings and save the sequence as TGAs in RGBA.
But every motion blur is rendered against black. :frowning:
I have tried it with:

  • MBlur
  • VBlur with nodes
  • OSA / FSA
  • rendered as PNG/TGA/TIF

I have only a bad compressed preview of the background video and for flexibility I have to deliver an image sequence with alpha. There is no chance to render the objects against the final background.
In 3D Studio Max there is “no premultiply” that is working with real motion blur, 2D blur and other 2D Filters, too. Maybe Blender need an additional premul mode?
In this case the color channels have the full intensity and only the Alpha has the gradient.

Any ideas? Is this possible with blender?

I have an additional alpha calculation in the sample blend. Without the calculation i have the same problems.

Attachments

simple_VBLUR.blend (199 KB)


But your sample renders with alpha, you just don’t see it in the renderwindow.
Once you save a file you can see it’s with alpha.

Pressing A with the cursor over the renderwindow shows the alpha channel.

Here is your file with your sample, just with another node setup - you can control the alpha with the ramp.
And FSA is a good idea for this.

Attachments

simple_VBLUR_changed.blend (177 KB)

Thank you for your help.

But that’s not the solution. :frowning:
You only reduce the Alpha, that’s not my intension.

I need some logic to rise the intensity of the color channels to 100%. So that there is no more black background in the color channels. The same logic should be implemented if you render with “MBlur” and “Key” without nodes. It’s a classic render setting.
I know the “A”-Key in Render viewer to switch between color and Alpha channels.
I see and understand the result image in PS and A-FX. I’ve done a lot of same jobs, but with other software than blender.
I’ve done some other jobs with blender, but now it’s the first time, that I want to render a sequence with motion blur and alpha. Never had these problem with other tools.

Maybe I got you wrong?

AlphaMattes are allways black to white. If your compositor does this dark edges try to use Premul instead of Key, because each software handles alpha different.

Here is another option of a node setup.
This time alpha and image, each got an own blur, perhaps this is what you want?

Sorry if I did’nt understand you, because english is not my native language.

Attachments

simple_VBLUR_changed_2.blend (173 KB)

hehe, same here. … “Sprichst Du Deutsch?”

The alpha is fine, I don’t want to change the alpha-channel.
But the color channels are blending to black.

Premul is not the solution. In this case the OSA/FSA blend to the black, too. I don’t want this. For OSA/FSA the “Key” should be the right decision.

My problem is the blending by the blur. Only the alpha should have the gardient and not the color channels. The gradient by the blur in the alpha is ok, the color channels are the problem.
The color channels should always have the color of the object only the alpha has a gray value, how the color must be blended.
omg - you see, english is not my native language, too. :wink:

Woher weißt du das?:wink:

After changing the colors in your sample, I can clearly see your problem.

I’ve just a dirty workaround for the moment(with the ramp again,hmm), but it makes things better, especially with higher blur and sample settings.

I’ll try a bit more later

Attachments



simple_VBLUR_changed_3.blend (176 KB)

I’m actually working on some other task of this project. (Sitze grade an einer anderen Baustelle von dem Projekt)
I’ll check your blend at first tomorrow mornig. (Morgen früh werde ich Deinen Test als erste anschauen)
I have a thread about the same problem on blend.polis. (Zu dem Problem habe ich auch einen Thread bei blend.polis gestartet)
MotionBlur für Compositing
Maybe with this info it is a little bit more clear. (Vll. macht es mit den Infos mehr Sinn)
There JulianH posted a blend, too. I’ll check both tomorrow morning. (JulianH hat mir dort eine neue blend geschickt. Ich werde mir morgen früh beide mal genau anschauen)

Where is the blur in your sample? (Wo ist der Blur bei Dir? Kann ihn leider nicht wirklich sehen bei der Farbwahl. Aber cool, dass Du die OSA Probleme fast komplett behoben bekommen hast)

It would be much more easy for me to continue the discussion on blend.polis. (Es wäre auch für mich deutlich einfacher, die Diskussion bei blend.polis weiter zu führen)

Thanx for your help (Danke für Deine Hilfe bisher)
Conz

Fleißig am übersetzen.:slight_smile:

I think the problem is related to the sad truth, that blender is not working in linear colorspace for now.
Therefore I have tried to correct the gamma before and after the blur.
This seems to work pretty good.
I know the color is bad for the blur, but better for seeing(or not seeing)the dark edge.

Viel Spass noch!

Attachments


simple_VBLUR_changed_5.blend (176 KB)

We found the solution (Thanx to JulianH).
With an “alpha convert” in the nodes all is fine.

I’ll attach a screen shot.

Thanx for your help.

Attachments