motorcycle turn and tilt ipos not working...

(ititrx) #1

:confused:

I dont understand whats up…

so , I have motorcycle, its 2 wheels/objects parented to the body/object…

I insert a frame with bike upright and parrallel to the x axis…then move the timeline to 4 and tip the bike over a bit, like riding a curve, and then turn the bike 30 degrees to the right.

Insert a frame. Then play it…I dont get what I expect, but instead, the rear of the bike floats off for the turn, and no tilting.

I played with this for some time, creating the turn so the rear wheel stayed in place and the front wheel turned, then I tried it on a more natural arc… but no matter what I do, it doesnt work correctly… I can have a turn, or a tilt, but not both…

what am I doing wrong?

You want the file? http://uploader.polorix.net//files/621/motercycle1.blend

thank you, this is really rattling my cage!

0 Likes

(Vertex Pusher) #2

You have your rotation/scaling pivot selected to the 3D cursor - change it to “Active Object” or “Individual Centers” and then key your rotations …

0 Likes

(ititrx) #3

I use two different centers, depending on the look… I used the cursor to turn the bike from its rear wheel. Trying to keep it in one place and have the front turn… instead of the rear moving off to one side for the turn…

But the ipo turned the rear instead of the front even after using the cursor.

I used the cursor to tilt from top view… which worked nicely in the ipo, but then the bikes rear did the jump thingy…

Looking very much unlike a bike turning a corner…lol

Then I used the 3d cursor as pivot to move the bike in an arc for the turn, that looked pretty good, but you dont see the arc when you play the ipo…

I inserted rot keys, not location keys…so maybe thats what I am doing wrong?

I am challenged… I cant see ipos in my head… they are just lines and I cannot make sense out of them…lol…I have tried, but cant find a way to make them part of me… so until I do, i dont get them…

I mean, all of them…I get x is for speed, and y is everything else…

But I dont understand the channel aspect…

so I muscle through it instead of doing it logiclly.

I thought rotation would set the keyframes up for the rotation of the object over time… the tilt… and the turn… but it does only one or the other not both together…

So, is moving the bike in an arc around the cursor, not a rotation?

HELP PLEASE! My dyslexia acts up when I am frustrated…which means I start to lose words…

0 Likes

(IamInnocent) #4

The 3D cursor can be any where at any moment in the 3D space. From that you can conclude that a simple rotation won’t be enough to tell Blender where’s the bike at all moment : you’ll need some Loc IPOs too.
That’s why there is a Ikey > LocRot shortcut.
Jean

0 Likes

(Fligh) #5

IPO’s are a Graphic (think graph) representation of the function they represent.

In the IPO window Loc-X (one IPO curve) with a Keyframe at zero (the solid black line going left-right) means that the object’s location is at the center of the 3D Grid on the X-Plane (where the RG&B lines intersect in the 3D window. If your next keyframe (say frame 10) is at 1 (one block up from zero in the IPO window) it means that at that keyframe the object will move 1 Blender Unit to the right in front or top views (in other words it moves 1BU along Positive-X). If it were at -1 (minus-1, ie one block down from zero) it would move in the Negative-X direction; to the left.

The same can be extrapolated to Loc-Y and Z. And the same can be extrapolated to Rotation, the only caveat being that rotation happens around the axis that is the function of that IPO (ie: Rot-X rotates the object around the X-Axis).

%<

0 Likes

(ititrx) #6

Ok, I played with again and get the bike to tilt and turn, kinda… but it still doesnt do the turn properly…

ALso.

Is there a way to play the ipo frames based on time the ipo has been playing?

I would like to hold down the turning key and oh wait, this is probably a game engine question… will post there…

0 Likes

(RamboBaby) #7

I don’t understand what you’re doing there because the file you uploaded only has starting keyframes and there is nothing else happening at all. I parent to a series of empties when I need multiple controll points. One empty isn’t enough when you need offset rotations for pitch roll, or yaw (like using the 3D cursor for rotation which is really bad practice for animations). ou also need to reset the center of the bike to the bottom of the wheels so that it doesn’t lift off the ground when it rotates. If you plan on doing wheelies then the bottom of the rear wheel is probably the best point to locate the center.

Edit: you can move to any point in time, select an IPO, tab into IPO editing, then SHIFT+S+4 to snap the currently select contrtoll point to the current time marker.

0 Likes

(ititrx) #8

Thank you fligh… I understand , I think…:slight_smile:

But when I actually do it…it isnt logical, what I see happening…

Also, if you use location ipos, then in the ge, you cant play it for a turn, because it will move back to the original location the ipo was started in…the first frame location. Which is probably not the location you are at now, in the ge…

sooooo, back to the drawing board…

0 Likes

(ititrx) #9

Hmm, I though I did move the center to the bottom, but on the front wheel, not the back… I have moved everything so many times… I have forgotten now…

I just uploaded the file so you could play with it…I did delete all the frame after the first one…since it didnt work…

sorry for the confussion.

I do not understand about parent to multiple empties for more control points? Perhaps you have a simple example file I can ponder on?

thank you…

0 Likes

(Fligh) #10

You need to use DeltaKeys (dLoc and dRot) for the GE, (one reason we like to keep GE stuff in the GE forum, or at least have posts labled “For the GameEngine”). DeltaKeys are Relative; the tell the object to move one BU in +X direction from whateve position the object finds itself.

Look in the Python and Plugins forum for a script by Broken that writes Delta from Absolute keys.

%<

0 Likes

(ititrx) #11

will do, thank you very much…

Yeah, I understand about the ge, which is why I stopped…lol

wait, is that the same script I used to write the ipo for the snake? no, I dont think so…

0 Likes

(RamboBaby) #12

Well, I made a file to upload and then I got this message at polorix when I tried to upload:

"Due to recent abuse of this free uploading service and as a result of overage charges from my webhost the uploader will not be online this month. I am sorry for any problems this has caused the legitimate users of this service. "

0 Likes

(ititrx) #13

LOL, so thats whats wrong there… but you know I used it just last night… funny…post it at www.4shared, please, and thanks…

Fligh!!! I downloaded and ran the script… I thought it would make the ipos relative but it just flatened them out? no turning… just down the x… seems odd dont you think?

Only in the ge though, they run fine in the the 3d window…

0 Likes

(RamboBaby) #14

http://www.4shared.com/file/25402409/eaa304a/OffsetRotationalControlls.html

Edit:
It’s a shame but I wonder what he means by abuse and overage? The only rules I remember is 200MB file size limit and no pornographic material. Maybe folks were running web pages off the site.

0 Likes

(ititrx) #15

ahh. I see. hmmm, yes you can use empties in the ge… sometimes I have more empties than I have objects, lol…

I have to think about this, because right off the bat, I dont see how this will help me…

Yeah, polorix says its unlimitted… so his host may be the problem… or he has just gone over his bandwidth… which I thought was unlimitted too.

0 Likes