Mouse and Keyboard Functionality is Limited

Hi!

2.8 is currently unusable for me, the program is not recognizing any keyboard keystrokes and will only allow me to select things with the mouse.

The middle mouse button does not register anything and I cannot select anything inside of the actual viewport. I am able to select buttons on the side and on the top menu, cannot pan or zoom.

All relevant drivers are up to date. I have tried using other keyboard/mouse combos with no luck.

I have tried to reset my preferences to factory.

Processor: Intel® Core™ i7-6800k CPU @3.40GHz
Ram: 16gb
Windows 10
GPU: Nvidia 1080

Here is the problem in action, in this I am trying to use my keyboard shortcuts, the mouse. I get a weird “Internal Error” pop up as I mouse over the viewport buttons on the left.

Imgur

I have been having this problem with 2.8 for awhile and it has kept me from using the program out of frustration. 2.79 works for me, I am able to work inside of the program with no problems at all.

I am at my wits end here with this.

Hey everyone, I received a working fix for this from BlenderStackExchange so I am going to share it here in case someone else runs into it.

Go to c://users/yourmachine/application data/roaming/blender foundation/blender/28 <-- this last folder should be the one with old preferences and is conflicting with other 2.8 installations. Delete it.

Run Blender 2.8 choose your default selection click but DO NOT change keyboard layout.

Your Blender 2.8 version should be up to date (daily developer version or DD).

Dowload Blender 2.8 DD. Unzip and run from the unzipped folder. Your configs should be reset to defaults and you should have no trouble driving Blender 2.8

And oh! please, please, close the antivirus totally and make sure the application is not firewalled on your windows configuration. Give firewall permissions to execute 2.8

The StackExchange link :

https://blender.stackexchange.com/questions/133091/blender-not-registering-keyboard-and-limited-mouse-input