Mouse pan/zoom too coarse and fast

Something happened to one of my Blender projects that has made the mouse pan/zoom a nightmare to use - I only need to move the mouse by about an inch to pan across a 15m long model with a ~2m field of view, and when moving (Shift+MMB) it jumps in big steps of maybe 30cm. Zooming with Ctrl+MMB suffers from the same problem, and the mousewheel zoom is just ludicrous, jumping back/forward what looks like 30 meters with each tick. Rotating the view (MMB) behaves a little better, with more control and less “steppiness”. This issue is driving me insane - especially since I’m now at a point in this project where I’m working on lots of small details, and moving around has become a real chore. I have looked through the User Settings several times, and have searched the web, but while I’ve seen others having simliar issues I’ve not found any solution. I have tried lowering mouse sensitivity in Blender settings to no effect (even at 0.1), but not in the OS - I’m happy with those as they are and have been using them as is for years. I found that checking the “Rotate Around Selection” option in User Preferences made things a little easier for me, but the fundamental issue remains. Grateful for any help!

2 Likes

Something I could suggest might be to scale up your model while you model it and then scale it back down? Also another thing you can do instead of panning to edit the object, you can move the actual object in increments by hitting the N key and going to the Location, Rotation and Scaling and move it in increments by holding the Shift key and mouse click

In User Preferences, Interface tab. Make sure Auto Depth is turned on. Blender makes calculation somewhere in space to try and figure out how to scale pan and zoom. With auto depth it uses the depth under the mouse cursor to better anticipate what your working on.

2 Likes

I spend a lot of time to find pan sensitivity and you made my day. God bless you :partying_face:
(Signed up just for it)