Mouse stutter with totally new and powerfull computer, only when Blending

My old setup was laptop MSI GT70 0NE (CPU Intel i7 3630QM, GPU 680M, Windows 7 Pro X64)
My new setup is laptop LENOVO LEGION Y740 (CPU Intel i7 8750H, GPU 2070 MaxQ, Windows 10 Enterprise X64)
Blender 2.81a (same Blender version with both laptops, I just configured my new one a few days ago).
In short the new setup smokes the old, rendering under Cycles is about 14 times faster, with the Optix option. And it’s much faster all around for all apps.
Yet… sometimes when I load a rather heavy file in Blender (when I say “heavy” I mean a file that was still manageable with my old laptop) the mouse has some stutter.

The stutter persists even when I leave Blender in the background and work on another open app. Blender is doing nothing at the time, no rendering no calculations.

(Now that I think about it, I have not increased the TDRDELAY value in the registry, which is the only setting I can think of that I have not copied over. I don not think this could be relevant? )

Are you viewing in ‘rendered’ mode? I seem to remember that can cause a bit of stutter as the GPU switches between updating the display and rendering (I have two GPUs so don’t suffer from that now)

No today was in solid view…!
Plus the 8750H has built in GPU Intel 630.
I was thinking though that somehow Optimus may not be optimizing the use of both GPUs.
I guess I can turn on MSI Afterburner to monitor activity of GPU , though my previous experience tells me, GPU usage in Solid Mode with Blender in the background is close to zero.

In that case, I don’t know then :slight_smile:

Have you tried switching from Optix back to CUDA or CPU?

@csimeon Is this solved ? Are you using a different mouse by any chance ? As in the ones for gaming, that do many (10k+) updates a second ?