Mouselook Navigation addon (+ZBrush mode)

Hm, what OS/CPU/GPU are you working with? To implement proper Z-buffer, I had to make a hack that grabs depth buffer contents on each redraw, but this might stall the OpenGL pipeline. I don’t experience any slowdown on my computer, but I have relatively modern CPU & GPU. However, if this is actually the case of your problem, then the original navigation of blender shouldn’t be much faster than Mouselook Navigation after the addon is enabled (because buffer-grabbing will happen indiscriminately).
I probably also should mention that, for some reason, Mouselook Navigation works slow when the User Preferences window is open. Did you check the navigation performance with the User Preferences window open or closed?

I have win7 64bit and core i7 4770K with GTX 780 so it should be fine , yes I was testing with prefs not closed and now tested with prefs closed :eek: and lag is gone .really cool! thanks. will use it for sure now !

Since I’m also using ZBrush, I have a very interested in this add-on.
Please tell me.
I think the grid is displayed when the Front Ortho,
When I rotate the view, Ortho-grid (and Background image) is scaled at the same time.
This is the thing of Kown issues?

· Known issues / missing features
“Ortho-grid / quadview-clip / projection-name display is not updated.”

Yes, this is one of them. Currently I don’t know how to solve it.

Thank you for reply.
I understand.
But,I think it’s very useful add-on!

hi dairin and thanks for the addon! :slight_smile:
is there a way to only use the alt-rmb - release alt zoom in sculpt mode?
can you tell me where to find that code so i can try putting it in an addon?

cheers christian

If you load the ZBrush preset, you can try to add a 3rd auto-registered keymap and set it up the same way as the 2nd one (except for specifying Right Mouse instead of Left Mouse); also, you’ll need to remove Sculpt from the 2nd row’s Keymaps and set Sculpt in the 3rd row’s Keymaps. After this, don’t forget to update auto-registered keymaps.

Alternatively, you can try to save the following JSON into the addon’s presets directory (e.g. with the file path like “…/space_view3d_mouselook_navigation/presets/ZBrush (RMB Sculpt).json”) and then load this preset in Blender.

thanks dairin, loading the preset works :slight_smile:
can you still point me to the part of the python code which makes it possible to zoom on releasing alt?
i’d really love to take that snippet of code and make it an addon for me to use within the default blender hotkey editor.

You’re welcome :slight_smile:
Ironically, the “snippet of code” which “makes it possible to zoom on releasing alt” is, basically, the whole addon. All the navigation functionality in the addon is implemented from scratch (and is tightly coupled), plus I had to make my own input system to handle ZBrush-style control schemes. So it’s probably easier for you to just use my addon independently from the default blender hotkey editor.

lol :smiley:
okay, i guess i will try modifying the addon instead then ^^
i would like to make it work only in sculpt mode … once i find the time i will try to modify it this way :slight_smile:

Hm, you don’t need to modify the addon for this. You can simply change the addon settings, for example, by removing the first two auto-registered keymaps from the modified ZBrush preset. I suggest you to read the documentation.

sorry, by modify i meant change the settings.
i will take a look, thanks :slight_smile:

Wondering if any work is still being done on this FANTASTIC addon. This has made my dream come true of using Blender on my tablet!

Currently though, it does not seem to load on Windows 10. Any ideas?

EDIT: Just did some tests and it’s actually not Windows 10 that gives the errors , it’s Blender 2.75a. It has no problem loading on 2.74 under Windows 10. So for now I’ll be sticking with 2.74 but a fix would be awesome!

Uh, just to notify anyone wondering, I have temporarily stopped all my addon development efforts (real life got too hectic). Though I hope I might be able to resume them in 2017.

Hm… I did a quick check, at least Blender 2.76b seems to work OK with the latest version of the addon I have. I forgot that there were some small uncommitted changes; I’ve uploaded the latest version as 1.0.6. (the download link is in the wiki). Hopefully it’ll work now.

Thank you very much for this this addon. No problems with Blender 2.77a. Thanks a lot!

Hello. I want to report a problem.
If you supply anisotropic filtering> 0 or MultiSample> 0, then my FPS down

Your awesome add on is a must have, that boost productivity for tablet workflow.
Thank you.

I noticed that fast navigate (option in the left panel, which uses temporary low resolution model during rotating the view, in multires sculpt) is not used when navigating in your addon, while it’s used with classic navigation in the same session.
the option is checked in all cases, but only active while rotating with classic key-shortcuts.
It could dramatically improve performance issues.

Wow… I was looking for something like this several times, but search gave no result, yet here is it, seems to be working well.
From zbrush methods only ‘selection’ works reliable for me with good enough performance.

Really blender should have an option to work like zbrush in sculpt mode.

Hi, sorry for late response.

In the space_view3d_mouselook_navigation/ file, there’s a line near the end:
addon.use_zbuffer = True
If you delete it or comment it out, the performance will likely improve. So far I was hesitant to remove it from the official addon, since certain features (like Auto Depth and ZBrush Z-buffer) rely on it to properly work. I’ll probably try to make it a user preference.

Ethan Aeris, I can’t find the “fast navigate” option anywhere. Can you please explain how to get to it / where it’s located?

Sure, here is the picture of the “fast navigate” option, in sculpt mode.
It is in the left panel, in options tab, in the option sub panel.
Please, don’t care about the first wrong image ,hard to delete the good one :slight_smile:
thank you for your interest.