moving through walls..help!

hi all!

i’m not the first one who asks this, but when i move around in my maze (making a maze game)
i go through walls! :frowning: and i don’t want that!!
how can i make it that my character won’t go through them?
there are a lot of other people asking this, but the answers are old, and aren’t helpful for me!

i’m using blender 2.49

thanks!
e.m.

(sorry for my bad english)

Are you using dLoc to move the character? Try force or a servo instead.

i don’t know whta you mean?! what is that, and where can i find it?

this is how it moves:

Like Magnum Opus said, switching it to Servo should fix it. Make your object Dynamic (where it says Static now, next to the Actor button). Then go to the Motion Actuators, and where they say Simple Motion, click and change them to Servo. You’ll need to put your speed values in again, and they probably won’t be the same as what you originally had, but if you play with it a bit you’ll get it.

mmmmm when i set my walls on dynamic, it falls down! even on servo?!

You just need to set the player dynamic, the walls should be static. And change to servo like mentioned above

put everything no collision if ya create maze in 1 object. create new mesh box or plane inside normal maze and set it as collision (bound - box) and set it invisible. alway working. OR put new plane as “earth” to stop your maze or character fell through floor.

check this tutorial: http://www.tutorialsforblender3d.com/GameDoc/Movement/Movement_Servo_1.html

nothing works guys! :frowning:

So all the movement is in your character right? Change your character from static to dynamic, and leave the maze static. Then the character should have the option to change the movement type to servo. That will keep it from passing through walls.

Also make sure you look at Monsters link. That should be helpful.

would you help me?
here is my file:
http://hotfile.com/dl/55474711/ea4815a/wotan-movement-in-maze.blend.html

please help guys!

I have seen in your file that your player consists of 3 objects. The gun and the player shape are parented to a small cube. Now I welcome you to the “great” limitations of blender.

  1. If you don’t want trouble in BGE, you must only use 1 collision per object. All other attached children (in your setup its the gun and the playerbox) must not have any collision. So you can set the small cube to have a collision. Set this thing to “Dynamic”

  2. Set Objecttype/Collision of Maze to “Static”

  3. Don’t use “Loc” to move an object because it will still go through walls. Instead use linV

mmmm yes its fixes, but i can’t go around the corner now :confused: :frowning: where can i find lin V?

Read the second part of my post again, and the link Monster posted.

sorry, i’m still going up…

and i don’t have locv?! look at my screenshot above!

linV will appear in the simpleMotion actuator as soon as you have set the object to dynamic.

ok! sorry for the stupid question!
but why am i going up? when i play my game, my character is going up?!