Multi-layered Eye Material Problem

I’m experimenting with a multi-layered eye with one ‘regular’ eyeball surrounded by a transparent sphere.

http://farm3.static.flickr.com/2244/1901692185_ab25d8e949_o.jpg

I have created this gap between these two spheres near the pupil and iris. The idea here is to eventually have the upper eyelid produce a nice shadow on the inner sphere over these two areas.

http://farm3.static.flickr.com/2403/1901692163_e90ad0153b_o.jpg http://farm3.static.flickr.com/2372/1901692169_6c206fa68f_o.jpg

So, I made the eyeball using three simple materials assigned to three vertex groups. For the outer sphere I made a simple transparent material with raytraced transparency (derived from the Clear Glass tutorial). Everything looks as intended this far.

http://farm3.static.flickr.com/2282/1901692175_53318d6d6a_o.jpg

Problem is, when I render both spheres together the eyeball turns black. I can’t find any more settings to alter, so I’m hoping someone here could tell me about that secret button hidden in that invisible panel somewhere.

Thanks for all hints and suggestions.

Mats

with the inner sphere selected go the the materials buttons, turn off shadow and turn on trashadow.

What Manti said. “trashadow” means receive transparent shadows.

You might want to turn on “transp” in the “Draw Extra” section of the object buttons. It allows transparency in the 3D view.

I have a tutorial on modelling an eyeball that you might want to take a peek at:
http://blenderartists.org/forum/showthread.php?t=85722

Cheers.

http://farm3.static.flickr.com/2184/1903686571_2d1f4fc31d_m.jpg

Thanks a lot for the help, it really worked. Yet another tiny button to keep in mind, sigh!

http://farm3.static.flickr.com/2288/1903686613_546a834aeb_m.jpg http://farm3.static.flickr.com/2003/1903686617_f390546171_m.jpg

However, I made this extremely quick eye to see what the shadow on the iris and pupil would look like. But there is no shadow. With the exaggerated distance between the the transparent sphere and the inner sphere there really should be one.

http://farm3.static.flickr.com/2139/1903686623_3e9548ab9b_m.jpg http://farm3.static.flickr.com/2351/1903686629_723418d6dd_m.jpg

I even placed a local light directly over the eyelid and rendered it with and without the outer sphere. No shadow!

I hope there is a second secret button somewhere.
/ Mats

check to see whether they are rendering (and receiving) raytraced or zbuffer shadows. Make sure ‘traceable’ is on both if using ray, and ‘shadows’ on both. If you are using buffered spotlights, they might be to soft to pick this up, but from the renders it looks like you are using ray anyhow from the renders. Are you using ‘emit’ or ‘translucency’ on the eye inside texture? both of those will mess with how much shadow you get…

http://farm3.static.flickr.com/2149/1905548386_a4aea87b08_m.jpg http://farm3.static.flickr.com/2058/1905548398_ef48bc9637_m.jpg

bendansie, I’m kissing your feets!

I enabled both Shadow and TraShadow in the Shaders panel, and Ray Mirror and Ray Transp in the Mirror Transp panel for all three materials assigned to the eyeball. This finally gave me the result I wanted. Lastly, I moved the lamp to its original location.

Side note: The human eye don’t have this kind of shadow, at least not this big. Some animals do though (see this image of a hawk’s eye for example). Just so that nobody gets it wrong.

Thanks everyone for the help
/ Mats

EDIT: Ammusionist, I finally clicked that link of yours, and I think I will spend tomorrow reading that PDF - thank you!
/ Mats