multiple imputs

Thanks to an upgrade, I can now use the game engine again, and the first thing ive noticed is that the controllers only seem to operate on one input at a time. I have an object that I would like to bank as it turns. I can only seem to get it to eather bank or turn but not both at the same time. Is there a new function that im not aware of or is this a bug. This happens regardless of weather I use key board or joystick input.


The sensor has this little button with a [’’’] in it that reads “pulse mode” when you mouse over it. That means if you toggle that your sensor will send pulses continually as long as the sensor is true.

Thanks for the reply. So much has changed in the game engine since I last used it Im at the bottom of the steep learning curve again.
I tried your suggestion, but it still seems to accept one input, and as soon as I add another imput it switches to that one and ignors the first. I am still testing different combinations of imputs, (loc,rot,force,torque,linv,angv) but it seems to affect all.
I have noticed that cameras created in 2.48 now dont work so it may be better to start completely from scratch rather than fix an old blend.
I suspected that I may have to use python, and my track record with python is abismal.


This is the first time Ive seriously tried setting somthing up using the bullet engine.
Ive noticed it seems specific to this game engine. Sumo, allthough depricieted, seems to accept the imputs ok. Has anyone else had this problem or devised a work around. Or is still a problem with my setup.