Multiple pinned cloth simulation : non-linked (but joined) parts falling, instability

Hey guys

I’m having some hard time with cloth physics simulation.

I have 120 frames of animation of my character and several problems with cloth simulations. I really don’t know how to unlock the situation. I will try to be clear and precise.

First, here is my rig + pinned cloths sim workflow :

  • Parenting the body to the rig : select the body, then the rig, Ctrl-P with automatic weights, then I weight paint. This is not the issue here.

  • Parenting the cloth to the rig : select the cloth, then the rig, Ctrl-P with empty groups

  • Parenting the cloth to the body : select the body, select the cloth, weight paint mode, transfer weight

  • Then adding cloth physics and pinning vertex : select the cloth, Edit mode, create a vertex group with 1 as weight, add cloth physics effect, and put the created vertex group as pin.

Then my body will follow the rig, and, in my mind, the cloths (pants, opened long coat) should be pinned on proper areas, and follow the rig, and so the body movements.
The body and the pants have collision applied.

Secondly, I have to principal problems :

1. Unlinked part of a cloth falling down during simulation

The character has a long coat. The coat is only 1 mesh in the outliner, but it has many non-linked meshes (buttons and seams) in Edit mode (Ctrl-L doesn’t select all the coat). This lack of global link makes the buttons and seams fall down during cloth simulation.

How can I solve this ? Linking every part of buttons and seams would take me a loooot of time, and, tell me if I’m wrong but, I can’t but the buttons and seams in the Pinned group of the long coat without killing th cloth sim ? (seams are on the sides of the coat)

2. Global instability (pants going through legs, long coat going through pants and body)

As my character is having rough movements to produce, the physics sim makes the long coat and the pants going through the body, no matter the settings values (Quality steps 12, collision quality 4, Stiffness 400 for every settings, Damping 0 or 1 for every settings, distance .2 for every cloth and collision object…).

I just need a cloth with “large width of bending”. Thats all.

In addition, after a while of testing, the Anim player is unable to play even 1 frame without freezing. So I need to force Blender to quit, delete every physics that I made, and do it again.
This physics sim effect is really driving me crazy.

A bunch of help would be appreciated here
Thanks :slight_smile:

Here either make buttons as non-cloth objects, keep them as cloth but make every button have a pin group in shape or connect buttons to coat (just connect the closest button certs to the coat).

Give body parts a collision from physics tap. On cloth objects give the self collision.
Now check modifiers on each object involved in going through problem. For the cloth objects: cloth modifier should be the first. For the rest objects: all is good.

Hope this works for you

Blockquote
Here either make buttons as non-cloth objects, keep them as cloth but make every button have a pin group in shape or connect buttons to coat (just connect the closest button certs to the coat).

Okay but I can’t have more than one pinned vertex group for the coat, and I would like to keep the coat in one mesh. I’ll try to put a weight of 1 for buttons and seams in the pinned vertex group. I’ll update you.

Give body parts a collision from physics tap. On cloth objects give the self collision.
Now check modifiers on each object involved in going through problem. For the cloth objects: cloth modifier should be the first. For the rest objects: all is good.

Body already has collision activated. In fact I think that clothes are going through the body in case of rough movements. Even with a greater distance collision, they still penetrate the body…

Idisabled the self collision as it makes the anim player very slow and almost always freeze (I don’t have my PC during the quarantine, I’m working on a Macbook from 2015). I’ll try to activate it again and see if it works

I’ve also checked the modifier order, and Cloth sim is the first. :confused: