Multitexture colour is different to GLSL

I am trying to work on a very simple, low-poly basic 2D game in Blender – so I don’t need GLSL – but one key feature of the graphics is the style of the colour palette. What I can’t seem to understand is why even when all the meshes are set to shadeless and object colour that they all change when starting the game. It looks like GLSL without Colour Management enabled.

Is there a way to enable this feature in Multitexture?

Thanks :slight_smile:

If you have no lights, everything is shadeless.

But I’ve never heard of the color change. Care to share some screenshots or a .blend?

In GLSL the color management is active by default, which is converting linear RGB to sRGB.
You can deactivate it by “Render --> Shading --> Color Management”. Or set “Scene --> Color Management --> Display Device” to None.

If the color management is off, GLSL should display the same colors as the multitexture mode.

Indeed, but I want to enable colour management in multitexture to make it look like GLSL’s colours.

That is not possible. Actually the BGE don’t use the color management for the multitexture mode.
The only way that I can imagine is, to write a python script that change for all objects the colors to sRGB on game startup.

Found an easier solution. Apparently the colour set by the material is incorrect. The colour set by the object colour is. So I’m just using one material – shadeless – with object colour. Works great.
Thanks for the support. That solution seems more elegant for complicated scenes where materials are actually used.

That’s the solution I use, swapping materials/textures during runtime is messy and complicated.