My BGE takes long to load with animated textures. Please help me. Quick question...

Hello folks. Whenever I use an animated 2560x2560 1.5mb tileset(you know, the picture with all the frames for the animation)that has 100frames, my BGE takes about 30 second to load. If I add more of these, then it becomes a pain. I always make them Animated UV Maps. What can I do to fix this? It NEVER happens when I use animations with only 30 frames, for example. Also, never happens with 5000x5000 uv textures that are not animated, but are UV normal maps. They are all UV maps. I doubt it is my computer, so please don’t suggest it. Oh, and just one more quick question: I have a super powerful mega lightning bolt .png that I made, and I’d like to know how games use these normal maps. Like… if I should hide the normal map behind the camera, until the character casts the super powerful mega lightning bolt or something like that? What exactly should I do? Please help me.

Oh, and I use blender 2.57.

Also, how do I make planes face the camera?

Thanks in advance…

100 256 sq textures mapped to 1 texture = something over a 5000 px sq image - can’t work it out exactly. Perhaps you don’t need 100 frames in an animated texture? Speeding up what you have, I don’t know.

For general game speed help, I’ve started a list:

Making a plane face a camera. I assume you mean always face the camera. Use the halo function. Halos are fussy, and even when I set them up exactly the same way, time after time, they always give me trouble.

His candle flame is a Halo. Just use that setup.
http://www.tutorialsforblender3d.com/GameDoc/Texture-Animate/Animate_GLSL_Step_1.html

<<2560x2560 1.5mb tileset>>
<<5000x5000 uv textures>>

Dear folk,
Blender should crash and give this console message:
“You must contact some professional game making studio!”
Bye

Dude, what I’m saying, is that no matter how many 5000x5000 images i put in, it starts RIGHT away. Now when it comes to ONE 2560x2560 picture with 100 tiles, it takes about 20 seconds, and the file isn’t even that big, that’s what I’m saying. And, it’s 2560x2560… What do I do? I can’t continue the project like this :expressionless: About the halo, could you explain to me what to do? I heard this before many times, but nobody tells how to do it on 2.5… I tried using the trackto logicbrick, after exploring, but it DOESN’T work well; the face that should face the camera, faces the middle, thus making the plane bent.

Now I tried with a 1300x500 picture with 60 tiles and it STILL TAKES 20 SECONDS TO LOAD??? OMG what do i do??? PLZ HELP!

The halo checkbox is present in the Edit mode tab (the wireframe triangle) when editing the face in edit-mode.

where is that? please be more specific… and what about the long loading problem? do you know what i can do? how the hell am i gonna make a rpg if only one spell already makes my game take 30 seconds to load?!

Dear dude
try the classic “power/of/two” image size: 128x128, 256x256, 512x512, 1024x1024 and so on!
Bye

I have created a game engine speed page:


Halo’s right above that menu. As to the loading, like OTO said, employ powers of 2 for your texture size. Also, 3D’s list is helpful to speed things up. Lastly, try making the texture really small - see if it’s the size, or if it’s actually the proportions / number of frames that’s making the game load slowly.

WOW, that halo option was really well hidden, I’d never find it by myself… but when I run BGE, it still doesn’t face the camera. Maybe I have to edit their position or something? If so, what do I do?

And I just tried a small texture with 7 frames only, and it takes the SAME amount of time than a 2560x2560 with 100 frames O.O…

it was a 1024x1024 texture with 7 frames. that’s really weird, dudes.

I already checked the blog, changed a few things, but still takes the same amount of time.

What do I do?

To make it face the camera, make sure the face is facing -X (and that there is no rotation on the plane object itself). You can see the rotation in the object properties menu (The N-key?).

Thanks man, it worked.

I don’t suppose you might, maybe, know what’s the problem with my BGE taking long to load…?

Open a new blend file. Add one simple prop with 1 texture. See how long that takes to load. You may have a ton of textures the GE is trying to load, and you just don’t know it. Try unhiding objects (Alt-H). Look on all layers. Look in the outliner. Export all of your textures to a file to see what you’ve got (File - External Data - Unpack into files). Don’t save of course, but looking through the result will tell you what images you’ve packed. The GE is trying to load data. You just have to find it. If you try my first suggestion with a basic object, then it’s your computer.

dude, i said it’s automatic no matter how many different 5000x5000 non-animated textures tehre are, but when it’s a 1024x1024 tileset with 60 frames(the entire image is only 1024x1024) it takes about 30 seconds

what do i do? this is so frustrating and i’m so sick of feeling frustrated with blender and its problems

Are you sure it’s Blender itself? Is there any other programs or applications running that’s taking power away from your CPU? What about your computer itself - how much RAM does it have? Also, if you try to load up that same 1024x1024 image without animation, it will load up quickly?

dude, i said it’s automatic

Dude.Don’t get snarky with me Dude. Just trying to help Dude. Help yourself then, Dude.

I think that the issue is your CPU starting the animated texture not loading the texture on your scene, so the problem isnt is the texture but your cpu, there are several hardware parts that ll decrease the loading time of the textures and the mesh of the scene but to compute the code to make the animated texture work the hardware needed is diferent from the last one.
Maybe is because of that

Calm down a bit - making a game means dealing with trial and error. Sometimes, things go wrong that you didn’t expect, and you have to deal with it to get your idea or game finished. Or, you’ll have to just figure out a different solution to the same problem. I know that it can be extremely frustrating to have to deal with something that you don’t seem to have control over, but freaking out won’t help things any.