My blender doesn't have Inflow and Bake

Hi, my blender doesn’t seem to have the Inflow option and Baking when creating a fluid.
Here’s some screenshots so you know what I mean

Because I am a new user I can’t put a second image to show that there’s no baking option, however you can see in this screenshot as well, that behind the drop down menu, where baking should be, it’s not

The Inflow option is under “Flow”. You can find the Bake option when you select the Domain and have the cache set to Modular.

Great tutorial, I’d just follow this through as it will teach you everything: https://www.youtube.com/watch?v=JYc_6fXEjw4

Also, read through the manual: https://docs.blender.org/manual/en/latest/physics/fluid/introduction.html