my blender flying camera mode doesn't move around with the mouse,please help.

I don’t understand how it happened, I opened my project and started working on it, as usual, then I alt-tabbed out to get a picture of a model, and when I came back the flying camera mod wasn’t working properly, I couldn’t use the mouse to move it around, only W,S,A,D to pan it, I tried to find a solution on the internet but I didn’t found it.

it should be noted that every time I close it and open the save file again, the flying camera works as normal, but with time it just stops working properly, I don’t know why.

I tried to open other save files of projects that I barely began and the camera got glitched there as well, for more than a week the camera was working normally, but suddenly it just stopped, I don’t understand whats happening.

can anyone help?

blender version:2.79

here are a few project files i made, one of my most elaborate work so far, and another with another project I barely began, so you can see the issue for yourself if you wish.

https://drive.google.com/open?id=1kKj2lFAu_RbaGTVsC6N0udLTuQbSZiSh

https://drive.google.com/open?id=1bkJQY364Pjnd9d1EyRgBXCPWLrUbgZ9o

Moved from “Misc: > Off-topic Chat” to “Support > Technical Support”