My bone animations wont render?

Hi, I am so hoping someone here can help me with this strange error :slight_smile:
I am currently in the process of rigging a character of mine an I’m not sure if this is a bug in 2.80 or if I’m doing something wrong.
Let me explain.

My IK controller bones for the arms (the target for the IK chain) wont animate when redered.
When I look att the animation in the viewport, this is what i see:

When I render out the animation from frame 1 you can see that the arm targets don’t move at all.

When I render the animation my IK controller bones uses the position they have in the viewport.
This is a animation rendered out when I am standing on a later part of the animation inside the Blender timeline. (The arms/hands have a different position)

  • The IK target bones do not have a dependency error.
  • I have tried rendering the IK chain with both 500 and 1000 iterations
  • I have looked everywhere I can think of to see if I somehow hidden the bone for animation but I might have missed somewhere!?

Any ideas!?

This is a screenshot from Blender if it helps.

I tried all I can think of short of redoing the entire animation.
I submited this as a bugso lets see how that turns out.

Have you tried single frame render from between the animation just to check if it matches with the viewport display?

Yes, single image renders works fine.
The first frame I render is always correct in animation also.
But somehow the bones don’t seem get any updated information and won’t move.

That’s weird… How about baking the animation and then render it out?