My enemy is sliding....

Why does my enemy slides after it chases me? any solution to not make it slide? and also not pushing me.

add “Materials” to all objects and play with the “DYN - Friction” settings!

Or in the motion actuators that you are using linV on, just switch them to servo.