My grid (floor+axes) are gone!

About halfway through a project, my grid and axes just disappeared, and now I can’t figure out how to get it back!

I’ve searched the web for solutions, but none of the ones I found worked.

Its not the view I’m in. Perspective, ortho, aligned, top/left/front, etc., its all gone. Changing shading modes doesn’t help either.

I go to different workspaces (layout, modeling, UV editing, etc.) and its gone there, too.

When I load the previous backup of the file, the grid is back, but I’ve done a lot of work since then.
Creating a new file or loading another project brings the grid back, so this problem is specific to this project.

My workaround is to just create a new file and copy everything from the current file to the new one, but this has happened to me several times before and I want to figure out what’s going on so I can restore grid without doing that.

I would attach the project file, but as a new user I can’t so I’ve put it in my public OneDrive linked below:!108&cid=A83B198CFA9884AA
It is the only item in there and I will remove it if this problem gets resolved.

Ok, so immediately after posting this, I went in to do my usual workaround. Here’s what happened:
With the old, gridless file open I did ctrl+n to make a new:general file. The new one had no grid either!
So I closed and reopened Blender and I got the default cube with the grid there, like normal.
THEN I went to open the beach1006 file, and the grid was back!
I tried opening the file directly from Windows, and the problem is still gone!

So, does this make my post a bug report?

You may have disabled overlays ? in the 3dview header


lol no, definitely not that. But so far, it hasn’t happened again

There’s a key command that does that. I can’t recall what it is, but I think it’s the same key that sets it back to normal.

I’m not sure if its a “remove overlay” command issue. I have that bound to a key since I use it all the time. I could still see the orange silhouette around selected items and empties and everything else, just no grid or axes.
It happened again when I was changing views from camera perspective (press 0 in numpad) to free-look orthographic (or it might have been when I pressed 1 for top down ortho)
So it seems to have something to do with switching between camera view and another view, or it could be the transition from ortho to perspective that did it.

Again, I quickly fixed it by closing blender, reopening blender with a new file, then opening my project.