My GTX 970 renders slower than my GTX 860m

Hello everyone,

I’m a little bit perplexed about the discrepency between the rendertimes of my Desktop and my Laptop computer.
Here is the full breakdown:

I have

  1. Lenovo Y50-70 Laptop with Nvidia GTX 860m graphics card - Win 8.1
  2. Custom built desktop pc with Nvidia GTX 970 graphics card - Win 7

Both are rendering the same animation file with the same settings:

  1. set to output PNG images at 2048 x 1080
  2. Samples are set to 576 AA
  3. Threads set to Autodetect and tile size 64 x 64

All render settings and lighting settings are the same, both are set to render with CUDA.

The problem:
My laptop outputs a png image file with a render time of 9-15 minutes on average I have rendered already 200 frames from the 800 frame file sofar with these consistent results.

My Desktop takes 1 hour and 20 minutes to output a single frame.

Troubleshooting attempts:

  1. Tried updating to latest blender version 2.77 -> 2.78a - No Improvement
  2. Tried updating Nvidia Driver to latest version as of today - No Improvement

I’m wondering if anyone has had experience with a similar issue and found a fix. Could this be the Graphics card that is acting up (lack of support from Blender or Nvidia) or something else?

The animation file that im rendering contains links to libraries (rig, props, materials, etc), I render using the console only as it improves rendertimes, and i notice that in the first stage of rendering where the assets are being verified and before actual tiles start to render that the Desktop is noticeably slower taking about 20-30 seconds to complete , whereas the laptop seems to do this instantaneously at around 2-3 seconds. Thought i’d mention it incase it was relevant.

Thanks in advance.

Does similar speed difference appear with all files or just this one? Test with some self-contained Blender test scene to verify that.

Does it render as slow with GUI enabled? How fast does it render with CPU (set small tiles)?

Hi, the only thing what can happen you have very small tiles for GPU render with Cycles.
The 970 has much more cores than the 860 and produce huge overhead with 64x64 tiles.
You should check with 256x256 or even 512x512 on this dimension…

Cheers, mib

Try this :

The similar speed difference appears with all files that i test. I only render using the console, which i run the program using cmd so that the render GUI doesn’t even run. I don’t think the problem is with the cpu because the i got a CUDA crash error while trying to render on the desktop today

I had orignally tried rendering with 256x256 tiles which worked fine on my laptop but immediately crashed the nivdia driver/cuda on the desktop. Switching to 64x64 seemed to work despite taking a long time, i did it on my laptop as well so i can exclude it as a variable.

I left the desktop to render for an hour and a half just to see what the output of the image would be, it crashed around 80% completion on the frame and outputted the image with missing tiles. After the crash it continued to render outputting blank image files and giving a repeated CUDA error.

Either your card is faulty or there is some kind of driver error. Since you already tried updating driver, it can be the card. Any chance of testing another card in this machine or testing this card in another machine?