My Marbles are floating above the plane.

I’ve got two marbles both set up with a collision and are Active, and a torus and 2 planes set up with a Passive.

One marble sits within the circle of the torus, which is half buried in a flat plain, while the other is a the top of a sloped plain.
The second rolls down the plain it’s on and bounces into the circle knocking the first marble over and out while staying inside the circle itself.
However whenever a go to animate it the first marble begins to float about halfway up the unburied part of the torus and seems to be rotating. The second marble starts above the sloped plain and rolls down it without ever touching it, and falls towards the flat plain hits into it a 1/4 of it’s mass before bouncing back out and hovering at half the height of the other, upon contact with the first, spinning marble, the second also begins to spin. Though, that’s to be expected. Both then roll to the torus, the first going over while the second stays within. Both do not touch the torus.

I’m uploading 2 pictures which are the first and third frames showing the marble rising, as well as the .blend if people want to have a look at it.

Thanks for any help, and if you need anything else I’ll be watching this fairly often as the day/week/year goes on.

Attachments



marbles why.blend (2.13 MB)

Quite a few things with your file:

a) Unapplied scale
Almost all objects in your scene have unapplied, non-uniform scale. This happens if you scale objects in Object mode without applying the scale afterwards with Ctrl-A > Scale.

b) Margin settings
The floor plane has a sensitivity margin for collisions of 0.040 - that’s what makes your spheres hover over the ground. Reduce that significantly, e. g. to 0.010.

c) (optional) Collision shapes
The collision shape for the second sphere is set to “Mesh”. “Convex Hull” might get cleaner results. Same goes for the slide: “Box” might get you cleaner results than “Mesh”.

d) (optional) Rigid body world
Under Scene > Rigid Body World you will find a “Speed” setting. I find the scene looks a bit more believable with speed set to 2.0.

e) (optional) Deactivation
If you want to prevent the first sphere from moving before the impact, check “Enable Dectivation” and “Start Deactivated” in its rigid body settings.

The rest is fiddling with bounciness and friction to have sphere 1 leave the ring and sphere 2 stay within it.

Render:


Scene file (zip, 670 KB)
OpenGL animation (AVI, 6.83 MB)

Used all of them which seemed to work and then I messed about with the bounciness and friction which messed it up again :o. Luckily I loaded the save and fixed it again as well as worked out the kinks. Thanks a lot!