My mind has become stagnant help needed....

Hello people .I have been stuck on this Ginger Bread man tutorial since God knows when and i can’t just seem to get pass the second part of the tutorial .Can any body please help me with this ?As i have personally considered this starters tutorial as the first stepping stone to the world of 3D animation (if im not wrong about taking up this tutorial like this and considering it the first stepping stone)…can any one be kind enough to help me with the part i’m stuck on in the Ginger Bread man tutorial? Please.

You have to be specific. We can’t read your mind.

I have parented Gus’s Armiture to his body .What do you have to do after this ?

Have i been specific in quoting my problem ?Any one?

somebody could ask a question like where exactly am i stuck? .Since i dont see any more replies in this forum maybe i thought a more specific question asked by any member in this forum would initiate more specific replies from me.so any one volunteers?

Ok, where are you stuck…what it means is, youve gotten to the armature, when you parent the mesh to the armature (make sure armature is inside mesh) then choose Auto Bone Deform (or something like that, cant remember exacts) and then animate…that simple.
have fun :smiley:

I think you did it backwards. You want to parent the body to the armature, not the armature to the body. once you do that, just select the armature, and go into pose mode ( ctrl tab ) and rotate a couple bones to see it it worked.

If any one has the Blender 2.57B Wiki Starters tutorial .Inside the second part of the Ginger Bread man Tutorial there’s a step where you parent the Armiture to the body or vice versa what ever you call it .I think i have followed uptil here correctly .But after this i get confused about the stuff related to the Vertex Groups and the order of the modifiers .Can any one please tell me according to the tutorial what to do next ?

Ok people i think i got the problem where i’m stuck .I’m not being able to select the individual Vertex group (i.e. the Right Arm vertex group ) .When i try to select the right Arm vertex group in the vertex group controls of the Object data context .The Vertices of Gus’s head get selected instead of the vertices of the Right Arm group . Where have i gone wrong ?Any body?

Make sure you have selected the right arm group. It will become highlighted in the list. And then try select again. If that does not work. Click Remove to remove those vertexes from the right arm group.

It has been a while since I did this one so I don’t remember what method was used for weight painting. But you can then select the arm vertexes and assign weights here. Or you can do it in weight paint mode.

This is what I also recommend for you. If you get to a place where you are stuck, go back before that in the tutorial to a place you had everything right. A great way to do this is save a different version for each step. When you get stuck, if it does not resolve, go back and recheck the earlier step to make sure you have it right and then proceed to the next step.

Put simply:

Having a problem now… go back one step. Keep going back until you find the place you have everything right and then proceed from there.

When i try to select a particular Vertex group (example the Right Arm Vertex group or the Left Arm Vertex group) .They dont select individually as displayed in the tutorial in edit mode .What am i doing wrong? .Does it have something to do with positioning the armiture modifier above the subdivison surface modifier as maybe in a previous step ?any body have a clue as to what im missing here?

to modron, you dont parent armatures to meshes, you parent meshes to armatures. Thats the only way the bone parenting menu comes up

One thing to check. Make sure you click on Deselect or hit the A key with the cursor in 3D view to deselect the previous vertex group or they will remain selected.

Otherwise the only thing that can be wrong is you have them assigned wrong. That is the only thing it can be. The modifier stack means nothing here. If they are assigned wrong, hit Remove and do it again. You may have accidentally assigned them.

If you are still confused. Do like I said. Go back to the previous step. Or simply practice the concept of selecting/deselecting and assigning vertexes to groups until you get the hang of how it is all supposed to work.

Richard ,are you talking about assigning the vertex groups wrongly ? You mean like when i assigned names to the armitures ?Can you please clarify this point you mentioned above:)?

If you used the method to parent the mesh to the armature then the bone names and weights were set up automatically. So if that is the case it would rule that out - basically. But sometimes this method is not full proof and sometimes the vertex groups get assigned in a sloppy way. When you select a group in edit mode for instance it will show every vertex, even the ones that might only have a very low value and have little influence. So it can be confusing. Going back to what I said before. Make sure you deselect them before trying to select another group.

Without more details of exactly what you are seeing, I can only guess. But it can only be these two things I mentioned. A) you are not deselecting so you don’t see a new group get selected separately or B) The vertex groups just got assigned that way. This is how you check -in edit mode because it sees all. And you can make corrections if needed. Automatic assigning is not perfect.

If you are deselecting and all is good there. You have nothing selected and then you select that group and it is wrong. Then fix it using the Remove button to remove selected vertexes from that group.

But this is a very tedious way to do add weights to vertexes as a general practice. It is much easier to paint it in Weight Paint mode. Then you can make corrections in Edit Mode. That’s how I do it.

Did you use the automatic method or does the tutorial have you creating groups (and names) and painting or adding values to them in Edit Mode?

evilmoonmoose, yes, that is what I said. parent the body to the armature, not the armature to the body.

@Richard .The sequence of things went like this from the beginning in 10 steps . while in (Edit mode):

1.I placed armitures in Gus’s body mesh .

2.After inserting the armitures i checked the ‘Armitures context display panel’ and did the settings for the armitures according to the tutorial.

3.Then i check the ‘Armiture Bones context display panel’ and name the bones by selecting them individually and naming them there.The names to the bones are automatically assigned accordingly in the 3D display view.

4.Then i select both Gus’s body mesh and armiture in (Object mode).

  1. The mesh appears dark orange after selection and the armiture appears light orange .The names of the bones are assigned as well to the bones while selected in that light orange color.

  2. After this i press ‘ctrl P’ and apply the automatic weights entry in the drop down list. This parents the body to the armiture .(If the sequence of selection is wrong regarding selection of Mesh and/or Armiture like before or after .Please let me know)

7.Now you select Gus’s body and switch to (Edit mode) .Where i can see the boxed vertices and the subdivision modifier enclosed within the boxed vertices in transparent form .The armiture also appears but is more highlighted in black within Gus’s mesh.

  1. Now comes the part where you have to select the vertex groups assigned in the ‘Object data context’ display panel under the vertex groups controls drop down list .

9.Here i can see the different vertex groups assigned .

10 .When i try to select a particular Vertex group like for instance the ‘Right Arm Vertex group’ .The vertices of Gus’s head get selected instead .When i try to box select the right arm vertex group .Both the vertices of the right and left arm get selected instead .This is the point where i can’t select the individual vertex groups separately .

I hope this helps regarding where the problem lies :slight_smile:

Go back and see if there is a point in the tutorial where it tells you to apply the mirror modifier. You should do that first. That would explain the problem of both right and left arms selecting. Apply the mirror modifier before you parent the body to the armature.

For the head problem see my earlier post.

I applied the Mirror modifier way back in the first part of the tutorial .Where you have to first make the Ginger Bread man ‘Gus’ .How ever in the second part of this tutorial (i.e the Animating the Ginger Bread man) there’s a step where after inserting the armitures in the mesh you have to duplicate the armitures and flip them to complete the mirror operation on the armitures .Thats just about it with the mirror modifiers i’ve done so far .Any thing else i should know?

At this point I’d just start over and go slowly making sure you get it right from the beginning. Start with a fresh new scene.