My model has major problems, even though I solved them with a different model

See, I’ve been trying to create renders of my Minecraft skin in different scenarios. I’m not very good at making models in Blender, so I make them with BlockBench (a tool originally created for Minecraft models but has a “free model” that is not restricted), export it as OBJ, and load it into Blender at which point I resize & position it as needed. View1 works fine and isn’t blurry, but View2 has been troubling me for days. See, the texture is blurry, and the model reflects light. That’s not bad for, say, the custom sword (which was accidentally backwards in View1), but for skin it is a problem because skin does not reflect light like a mirror would. Another problem with the reflection is that it is reflecting off the empty space around the sword, meaning I had to move the sword into the sheath for it to not look so awkward. View1 originally was blurry, but I fixed it. That fix isn’t working in View2. Can someone give me a step-by-step tutorial on how to fix both of these problems in View2?

1 Like

If you don’t want lighting and shadows, put an emission node instead of a diffuse or principled node. At strength 1, it doesn’t glow, it just sets the shading flat.

There are a lot of different questions here and each one of them deserves its own thought.

How would I do this exactly?

Also, how do I get rid of the blur?

18%20PM

Where is that? I can never seem to find that thing, but it’s referenced in a whole bunch of tutorials.

Click the “Shading” tab at the top of the screen

Top of my screen

@AwesomeNinja886 I thinkk @horusscope forgot to mention that your render engine should be :arrow_down:

Blender_Cycles INSTEAD of Blender_Render.

I’ve tried cycles, but the problem is that it
a) lags when I try to render the image and
b) renders white instead of the texture.

@AwesomeNinja886

I thought so too when I first started Cycles.
Turns out you just need to LOWER the SAMPLES & LIGHTING in the options here :arrow_down:

[1] Make sure your on Textured_View.
[2] For image_textures to show on a object, you need to first set them up in the Node_Editor.
[3] (Maybe too much ambient_occlusion (?))

Welcome to the forums. :slight_smile:

Maybe if you were to post your .blend file, it would help us to be in a better position to assist you.

I’m a new user, so I can’t upload attachments…

Hold on a sec, maybe I can bypass this with Mediafire:

https://www.mediafire.com/file/2otdo4jh0flsol6/AwesomeNinja_Blender.zip/file

Oh yeah, I have tried Cycles and actually managed to apply the texture… it’s still blurry and it still lags. I haven’t tried the lowering samples & lighting tip yet, so I may do that in a sec.

View2_Test1 is the original
View2_Test2 is a modification where I tried to make fog, but it didn’t look very good overall
View2_Cycles_Test1 is where I simply went from Render to Cycles and applied the texture (still blurry)

EDIT: View2_Cycles_Test1 is based off of Test1, not Test2.

It looks like the differences between the views are that View 1 uses a single-light setup while View 2 uses a three-light setup. Also, the environment color is cyan in View 1 and red in View 2.

I changed View 2 to the light setup of View 1 and changed the environment color to cyan, then I reduced the specularity of the material that you’re using to zero in View 2. I’m rendering it in my viewport using Blender 2.80’s Eevee rendering engine. I’m not noticing any blur or any huge reflectivity issues:

If I change the environment to red and add a couple of more lights, still no troubles that I can see. There’s a little more of that reflectivity that you mentioned, but it looks like normal light interaction:

If you want something with zero reflectivity, then the Emmision material that someone mentioned earlier is a good way to go:

You’ll have to forgive me if I’m misunderstanding your requirements - I’m still a relatively new user myself and I don’t have any idea of what you’d need for Minecraft.

Close.

I’m sort of trying to get it where the knuckles light up on the gauntlet, like my character is exploring a dimly lit cave/room and is using the gauntlet to light the area. However, the low-res image is blurry, and the reflectivity thing is also a problem.

Also, I’m on a Mac. so the UI is different.

Also, the stuff in the model is not exactly from normal Minecraft, but based on my Minecraft skin. I added the now-removed Quiver item from older versions (retextured to my liking), a custom sword, and a custom sheath. The gauntlet is inspired from Minecraft Story Mode Season 2, but the use I imagine for it is all my own.

It is just that the low-res Minecraft textures aren’t blurry, and my render’s texture is, which I need to fix somehow. Plus that reflectivity thing doesn’t look good for skin.

Hmm. I would say that your first bet to light the gauntlet would be to play with your light setup. You could move your lights around the scene a bit. Maybe play with the Strength values. The Emission shader, if you set the strength to, say, .8 or something, will light up whatever it’s attached to like a Christmas tree. Someone once told me that lighting is what makes or breaks just about any 3D scene - I haven’t come across many cases when this isn’t true.

As far as the low-res is concerned… I have no idea what you mean by it. If you’re rendering out properly in a separate window and not in the viewport as you go along, there’s a setting for Output Resolution in the Output tab. I don’t know 2.79 or Macs, so you might have to hunt for that. You can even bump the resolution up to 4K or higher if you have the time to wait for stuff to render.

There’s no earthly reason why anything should look low-res if you render in high-res because you’re not actually using images for textures.

I could still be off-base - can anyone else shed light (heh) on this?

The ZIP also included screenshots of the renders. You’ll see what I mean.

I went through the process and imported your OBJ with MTL into a blank Blender file, then started looking at UVs and stuff. Did you know that your texture map is only 128 pixels x 128 pixels? 1024 x 1024 is even kind of on the low-res side these days.

Also, you might want to scale your character - after I imported it into blender I realized that it’s around 26 feet tall. That might not be a huge deal, but it might affect the way that you work with lights and stuff.