My model won't export to FBX

Is is because the hammer is clipping with the handle? can i have the objects clipping, or does it have to be set like that in-engine? (don’t worry, these are stand-in assets for making the game feel good before i make more decent-looking assets) i can’t upload attatchments because i’m a new user, so i guess ill have to describe

Are you sure it isn’t exporting correctly? O is it not importing into the game engine correctly?
I have exported a cabin with intersecting geometry into UE4 without any problem. Simple test, once you’ve exported the FBX, can you import it into a new blend file ok?

You can upload blend files to http://pasteall.org/blend/.

Intersecting geometry is no reason for not exporting.

(It can only cause problems with lightmapping or skeletal mesh deform.)

Ah, sorry, I didnt find that way to send blender files, here is the link http://pasteall.org/blend/index.php?id=51606 im not planning to keep those files in the finished game, but i want to find the cause of this.

Only select what really needs to be exported then check “Selected Objects” in the exporter settings. Which engine is this for?

This is for Unreal Engine 4, but i’ve already tried that and it still wont export, did it work for you?

In UE4 a skeletal mesh can only be one mesh, so the lazy solution is to just merge the hammer and the arms into one mesh, but this is a very limited setup. Obviously, you won’t be able to switch or hide the gun. The proper setup is to export the arms and the armature and import it as a skeletal mesh, then export the gun seperately, then attach the gun to the “hammer” socket of the skeletal mesh inside the Character Blueprint.

1 Like

Thank you so much! I didn’t know people responded so fast!