My not-so-solid floor and other newbie issues

Hey all,

I’m trying out the game engine seriously for the first time, trying to make a little runtime for an EFL class I’m teaching. The idea is to use it to work on one’s ability to understand and follow directions. Voice clips will play, using realistic language to tell you how to get to another place in the town. When you find that place, you get your next set of directions. More details may be added later, but for now that’s the gist of it.

But newbie problems abound:

The “city” will be placed on an island. I’ve got my navigation controls working and a temporary UV texture on the island, but I keep falling through the texture unexpectedly for some reason. I’d like to figure out why this is happening before I mess up a more complicated texture.

Also, I’m simulating gravity by putting a constant downward velocity on the actor. A canceling upward displacement is triggered by texture collision. Fine and dandy, but when I’m at rest, the picture jitters up and down slightly, because this method is making me bounce on the ground. I’m wondering if there’s a better way to do this, and if the way I’m doing it now might be related to the falling-through-the-ground problem too.

One more: When I do a runtime, a small building I’ve added loses its UV texture and appears white. I’ve reduced the image to 256 colors. I’ve made sure the size is a multiple of 64 pixels. I’ve cleaned out the packed images and repacked the corrected ones. Is there anything else I might be missing? I don’t know why the textures won’t show.

Any help is much appreciated.

Thanks,

-Daniel

press F key to go into face mode. Select the faces you are having problems with and click on edit buttons. You will see a button that says “collision” make sure its pressed and click “apply to all faces”

master of gameblender,
RonC

Thanks for the pointer. I’m sorry, but it’s late and I must be going blind here. I’ve looked all over for anything that says “apply to all faces”, but I can’t seem to find it.

Ok here comes some help: :stuck_out_tongue:

Falling/moving trough objects problem:
It’s because the meshes you touch or use in the game don’t have materials asigned to it. The way you can fix this is.

  • go to the materials buttons, just create a material and call it level (or whatever you want) then select any mesh in your game, then go to materials button and asign that material to that mesh. You can use 1 material for your complete game unless you use materials for collision sensors. This fixes the go trough everything problem
  • when your character or objects are still going trough things, check if you use DLoc or DRot, if you do, try to use Torque or Force. Another thing I discovered is, example: if you use 1.00 DLoc for motion, add just 0.50 force at the same axis in the same motion actuator, this seams to fix the DLoc problem. When you use DRot, you can add a little torque in the same actuator. :stuck_out_tongue: (works perfect, but you have to find the nice amount the get the desirec effect.

Question 2?
MMhh I don’t understand that question, sorry :frowning:

Textures disappear in runtime (exe) files.
This is because a runtime isn’t more then a package, and your textures are still outside it, so you have to put them inside the package (runtime.exe) Ok we fix it right now. Open your .blend:

  • Blender 2.25 > go to ‘Tools’ in top menu, select ‘Pack file’.
  • Blender 2.34 > go to ‘File’ and in the bottom of it, you see ‘Pack file’
    This will fix the problem, you can also unpack it when you lost the real textures :stuck_out_tongue:

I hope this help 8)

Thanks for the advice.

For problem 1, this helps a lot. I’m still falling through in some steeper places, but I was eventually going to put those “off limits” anyway.

Problem #2 was taken care of by problem #1’s partial fix.

Problem #3 is still there. I tried packing the file again, but it just isn’t working for that one UV map that the house is using. FWIW, it’s 640x640 pixels, and uses 256 colors, so I don’t see why it won’t work.

-Daniel

Maybe a broken internal link, try to link it again. The blend file is remembering the paths to the external files. When you pack it it uses those paths but don’t update them. This means when you have a cube textured, move the picture then, the game engine still shows the image, but when you pack it, it uses the same path but can’t find the image there. So it doesn’t pack anything. So remember that the .blend files always display there images even when the image isn’t on that path. When you pack it, it uses the path that’s wrong, and thinks: ‘hell crap no image = no image in pack file’ that means: image path = error, packed no image. (while is shows up in the blend file) Opening again these textures would fix the problem, unless the textures are still in the same dir on the same place on you harddisk, then it should pack them. Also remember changing names could give errors in the paths.

Wow, did anybody who answer this post read the whole thing? You’re not using the blender physics engine, you’re applying downwards force instead, which, when not coupled with the physics, won’t work. Period.

The first step you’ve got to do is go to the world buttons (hit F5, and then click the little button that has a picture of a planet on it) and then change the pulldown menu under mist/stars/physics that says None to Sumo.

Now click the gamebuttons (button with purple pac-man) and enable acter and dynamic.

Now your object will actually use physics. Now assign the ground object a material by hitting F5 (or clicking on the shading buttons) and click add new. Now your object will fall by itself and it shouldn’t go through anything.

For your texture problem, try selecting the faces, removing the texture (click the little X next to the name of the texture in the texture window) and then reapply them.

One more thing: Doogs, there is no button that says “apply to all faces” it’s called “copy drawmode.” Don’t go around calling yourself “master of gameblender” when you can’t take the time to check your facts…

Pooba