my objects aren't rendering

Hello people,

i’ve been having this problem for a while, and now i’d like to solve it.
whenever i render my scene, no objects show up, and only the background is rendered.

i’ve already done some troubleshooting.
the object is in the render layers (or better, it’s set to render all of the layers),
it is renderable (is that even a word?) in the outliner,
the faces aren’t flipped in the wrong direction,
and there is no transparency set.

i’ve been having this problem in blender 2.5, but when i switched to 2.6 (which i’m using now), the problem still occured. it happens in all projects, with all objects.

does anyone know what else could cause the problem?

my best wishes,

Did you forget to enable “Do Composite”?

i’m afraid i didn’t. compositing is on.
perhaps it helps if i attach a screenshot.

so the background color renders fine, just the object itself doesn’t.
i’t rather not reinstall the program because of my settings.
if it turns out i can’t solve this, does anyone know a way to save the settings?

The screenshot doesn’t really show anything useful. Just attach or link to your blend file.

sorry it took so long. i had something important to do (yes, even more important than blender). since it’s happening to all my recent file i’ll just give a copy of my default file.
i hope this’ll help.
(ps. the image was ment to illustrate what i ment, but i can see how that isn’t very helpfull).


blender.blend (459 KB)

Add a lamp to your scene and turn off Zmask in the render layers.

You don’t need all those passes either, you’re just extending the time it takes blender to render the scene.

This is not the default scene you got when you started using blender, you’ve changed it. Use File / Load Factory Settings, then Ctrl+U to save it to get back the original default scene.

(ps. the image was ment to illustrate what i ment, but i can see how that isn’t very helpfull).
The end result is irrelevent, how you got to that result is the important thing and the screenshot showed none of your settings for materials, scenes render settings etc etc.

that did it. thanks a lot.
i really have no idea how that got turned on (i never use it),
but it doesn’t matter, cause now it’s turned off.
thank you, and thank you all :slight_smile: