my objects in the compositor are half invisible!!

Hi.

I am working on a progect for my uncle and i go to the compositing stage. I used mix nodes to bring together my elements and they are transparent. please help



With that many nodes who can say just from looking at it? A packed .blend would help. But if I had to guess at a glance I’d say it involves several of your nodes being set to Screen. Revisit the different blend modes and what they do. Also you’ll probably want to use the Viewer node to inspect what output is coming from your node tree at each step.

Replace your last mix node before composite output to an alpha over of the spaceship. Assuming your spaceship render layer has transparent background.

If you use screen to overlay the images, everything black on the image will disappear and some parts of the satellite (sorry, if it shouldn’t be a satellite :D) are black, so the Screen node make those parts transparent.

You should render the things with transparent background (turn off Sky in Render Layers or under the Render Tab and Shading set Alpha to Transparent) and then use Alpha Over instead of Mix-Nodes.

I hope that made sense :smiley: