My particle simulation baking stops at 250 frames, bake has no time settings!

I started working with the improved sph particle system, i tried a small number of particles (3000, the animation needed no more as its not used for fluid despite compute method) but the animation only bakes 250 of my 500 frames, the bake tab in particle settings does not have bake time settings to change frame boundaries (or whatever you call them!)
i am stuck, i will post the .blend below. Blender particle experiment.zip (1.69 MB)
Help MUCH appreciated!

~TheGPUguy

I think you just need to change the end frame number to the frame where you want the bake to end. You might need to clear the cache before re-baking.

Also Check in the Emmitter Settings the Start and End remember that is when the particles start coming from the object and when they stop coming from it. If it is 1 and 200 it will start coming at the first frame but will stop emmiting at 200 and you will still see the particles that have already come out but no new ones will be created.


I am terribly sorry, i linked an old version of the file, but i have tried both of these things, and both have failed me. i changed the end frame to 500, and the last emitting frame to 400 (i did this because the animation was too fast for 48fps)

The main problem that i have found, is the red bar that comes up when you have a particle bake does not stretch to the end of the light grey area of the animation, i don’t know how to extend this, it has never happened to me in previous builds. i have even tried removing the particle settings and adding a new one, to no avail.

more suggestions will be most appreciated!

Thanks guys! Much appreciated!