My robot jumps up after I constrain it to a path and attempt to move it.

I am trying to move my Robot along a path. I am following the directions of a tutorial I once did here (second half of third video). I made an action strip of it clapping. It wasn’t restrained by the path. Now I want the Robot to move along the path and I then I’ll add a walking action to the movement. I want the walking action strip to blend with the clapping action strip. For some reason, as soon as I attempt to move the Robot along the path, it jumps up and stays above the ground. I was able to make this work in the original tutorial. But now as soon as I attempt to move my Robot, it jumps up and stays above the ground. I know I have to animate the path. But this is where I am having the problem. Can someone tell me what I am doing wrong?

Blend file:

You got the robot rig and the jbk4rig. The jbk4 is the one jumping to the curve. I would just use a bezier if you can. I think it needs to be Bezier it worked for me.
That robot is cool.

Well, even though I still have issues with animating on the curve, I’ll mark my problem solved. I hadn’t thought about the JBK4 armature. Somewhere along the way, I decided I didn’t like the name JBK4, so I made up a new name. I didn’t delete the old rig, because as a newbie, I was afraid I’d lose something important. So now I’m paying the price for straying from the tutorial’s directions. I did try using a bezier curve, but my Robot gets all distorted. So now I’m rendering my animation in sections and the Robot is on the ground the whole time. But because I wanted the robot to have a fixed position for the clapping action at the start of the animation, I had to render that action before I constrained the Robot to the curve. Maybe some fade in effect will work…

I had this all set up perfectly on the curve at one point, but after rendering 600 frames, I noticed in the clapping action, the Robot’s arms were going through his knees. So I had to fix that, and I never got the curve to work right with my Robot again. I do appreciate you taking the time to see what my problem was and responding.

The Robot is from following: